1

I'm running bitcoind on a debian web server. If I run in normal mode, i.e. "bitcoind -daemon," then it seems to work completely fine.

[birdseye]$ ./bitcoind -daemon
Bitcoin server starting
[birdseye]$ ./bitcoind getinfo
{
    "version" : 80600,
    "protocolversion" : 70001,
    "walletversion" : 60000,
    "balance" : 0.00000000,
    "blocks" : 184222,
    "timeoffset" : 0,
    "connections" : 1,
    "proxy" : "",
    "difficulty" : 1583177.84744401,
    "testnet" : false,
    "keypoololdest" : 1396494743,
    "keypoolsize" : 101,
    "paytxfee" : 0.00000000,
    "errors" : ""
}
[birdseye]$

but if I run it with "-testnet" (which I kind of need to), it starts up... but gives no response. Ever.

[birdseye]$ ./bitcoind -daemon -testnet
Bitcoin server starting
[birdseye]$ ./bitcoind getinfo
error: couldn't connect to server
[birdseye]$ ./bitcoind stop
error: couldn't connect to server
[birdseye]$ ./bitcoind help
error: couldn't connect to server
[birdseye]$

I'm kind of at a loss. What's going on here?

update 1:

recent .bitcoin/debug.log

2014-04-03 16:57:36 getblocks 101541 to 000000000001ac70cc5a1d15886a46f56f45b9c58b7f1a01e83b9f29e11fc3ae limit 500
2014-04-03 16:57:36   getblocks stopping at 101589 000000000001ac70cc5a1d15886a46f56f45b9c58b7f1a01e83b9f29e11fc3ae
2014-04-03 16:57:36 received block 000000000000043ad22dd84318ca2671e5b6046746056b6e87e231b725147a34
2014-04-03 16:57:36 SetBestChain: new best=000000000000043ad22dd84318ca2671e5b6046746056b6e87e231b725147a34  height=184882  log2_work=68.274512  tx=4195579  date=2012-06-16 23:53:21 progress=0.044423
2014-04-03 16:57:36 ProcessBlock: ACCEPTED
2014-04-03 16:57:36 stored orphan tx f90973582dbd0843532d9f633fd9dfbd55415206e901e889d9cfa1a515ea075c (mapsz 44)
2014-04-03 16:57:36 getblocks 101541 to 00000000000161cdee61f93a1273ed30430a8dc291b39cff7b141a6e795732a6 limit 500
2014-04-03 16:57:36   getblocks stopping at 101596 00000000000161cdee61f93a1273ed30430a8dc291b39cff7b141a6e795732a6
2014-04-03 16:57:36 received block 00000000000005206a91cb78e77786950eef356915fdfd65846c1bbdb95cc3c1
2014-04-03 16:57:36 SetBestChain: new best=00000000000005206a91cb78e77786950eef356915fdfd65846c1bbdb95cc3c1  height=184883  log2_work=68.274539  tx=4195806  date=2012-06-17 00:00:59 progress=0.044426
2014-04-03 16:57:36 ProcessBlock: ACCEPTED
2014-04-03 16:57:36 getblocks 101541 to 000000000002d1c84a22fc060a77ab23e639901ba88799ba6967681e8963de58 limit 500
2014-04-03 16:57:36   getblocks stopping at 101599 000000000002d1c84a22fc060a77ab23e639901ba88799ba6967681e8963de58
2014-04-03 16:57:36 received block 000000000000065eac0093fce961495df4af73a9c8dd5b85dbfe800fc76ef135
2014-04-03 16:57:36 SetBestChain: new best=000000000000065eac0093fce961495df4af73a9c8dd5b85dbfe800fc76ef135  height=184884  log2_work=68.274567  tx=4196263  date=2012-06-17 00:25:44 progress=0.044431
2014-04-03 16:57:36 ProcessBlock: ACCEPTED

recent .bitcoin/testnet3/debug.log

2014-04-03 16:55:22 SetBestChain: new best=000000004360c981d6d3d03d1958387603756a8e81525f0fff3abdc07e4c3020  height=205584  log2_work=58.170804  tx=1261027  date=2014-03-20 13:43:14 progress=0.996614
2014-04-03 16:55:22 SetBestChain: new best=00000000233a20dac8d9d2bc567cd0310c131d6c0e30f0303852bcc7acad94cf  height=205585  log2_work=58.170804  tx=1261032  date=2014-03-20 14:03:28 progress=0.996617
2014-04-03 16:55:23 SetBestChain: new best=00000000c7e3c0ec5c9754255a5ef8fff30012cb9b41393515a2cb1582d5c563  height=205586  log2_work=58.170804  tx=1261082  date=2014-03-20 14:24:16 progress=0.996621
2014-04-03 16:55:25 SetBestChain: new best=00000000c004c6a0df7518bc7ed9e40c64dee5fd5a8368b5105c357504fbf04c  height=205587  log2_work=58.170804  tx=1261175  date=2014-03-20 14:44:43 progress=0.996625
2014-04-03 16:55:25 SetBestChain: new best=000000000003288e241b9a9728a7dd9944a24e8df7b7521a15254e0a46fb9bd7  height=205588  log2_work=58.170856  tx=1261207  date=2014-03-20 14:37:50 progress=0.996623
2014-04-03 16:55:25 SetBestChain: new best=000000000004a9078edbc6c6634d77dad567c92264123e8c7037ff6f1a9b128f  height=205589  log2_work=58.170909  tx=1261219  date=2014-03-20 14:45:13 progress=0.996625
2014-04-03 16:55:30 SetBestChain: new best=00000000d52dff17b26e6e01e7617ce8799188560c89992bde146cb8dcf0f8b5  height=205590  log2_work=58.170909  tx=1261328  date=2014-03-20 15:05:17 progress=0.996628
2014-04-03 16:55:30 SetBestChain: new best=000000000001571e38ac949a3a81473548af9851c1244596beae02b061cfb842  height=205591  log2_work=58.170961  tx=1261343  date=2014-03-20 15:12:13 progress=0.996630

the testnet one is just setbestchain, setbestchain... over and over. Google isn't giving me very clear answers on what might be causing this.

UPDATE 2: this problem does not occur with Litecoind. My litecoin.conf file is almost identical to my bitcoin.conf, except the litecoin one has these lines included.

daemon=1
server=1
gen=0

UPDATE 3: I deleted my entire "testnet3" directory and re-ran ./bitcoind -testnet -daemon. It worked perfectly and responded to RPC calls UNTIL it downloaded the blocks to a point about 10mb beyond the point it was hanging up on previously... then it stopped responding again, and shortly after, stopped downloading blocks. Still no solution in sight.

  • Could you check if the testnet chain is actually being downloaded please? – Jori Apr 3 '14 at 15:18
  • I'm not entirely clear how to check that, but there are a bunch of "blk000#.dat" files in the .bitcoin/testnet3/blocks directory. – Tisra Apr 3 '14 at 15:25
  • Check if their file size grows. That should give an indication where the problem is. – Jori Apr 3 '14 at 15:50
  • good call... they aren't growing. It's stuck at blk00004, which at 50331648 bytes is a little less than half the average size of the previous 3. I've had it running for half an hour and there's been no change in size. – Tisra Apr 3 '14 at 15:56
2

You also need to use -testnet when connecting to the daemon. Try

 ./bitcoind -testnet getinfo
  • well, that changed the error message to "error: incorrect rpcuser or rpcpassword." fiddling with the .conf files didn't fix it. – Tisra Apr 3 '14 at 17:56
  • If you changed the password in the conf file in the meantime, the daemon may not have seen the update and still be expecting the old one. Try killing the daemon and trying again. – Nate Eldredge Apr 3 '14 at 19:11
  • no change; still giving the same error message. – Tisra Apr 3 '14 at 19:29
  • @Tisra: Huh. Maybe you could post the conf file? – Nate Eldredge Apr 3 '14 at 19:33
  • rpcuser=bitcoinrpc rpcpassword=[my password] rpcallowip=127.0.0.1:9332 rpcport=9332 alertnotify=echo %s | mail -s "Bitcoin alert" [my email address] – Tisra Apr 3 '14 at 19:41
1

Answering my own question. Apparently, at that point in the blockchain, the daemon started chewing up processor space and the server's resource watchdog promptly killed it. Starting it with

nice --20 ./bitcoind -daemon -testnet

seems to have more or less made the entire problem go away.

I feel a bit stupid now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.