0

My MultiBit wallet won't open, because "Java is not installed", though I have Java 8, 7u51, and 6u49 installed... Which version of Java should I have installed?

1

Check out the installing guide for Multibit, looks like there is a common problem with Windows.

It could be you have the wrong Java architecture installed (for example you might have 32bit but need 64bit. Or Maybe multibit requires 32bit java even on a 64bit system).

Oh and one of the suggestions on the multibit page suggests running the program in compatibility mode.

When you have a problem like this always try re-installing java. Download and install it the typical way from https://www.java.com/en/download/

3

Define a JAVA_HOME environment variable with the path to your jre/jdk installation in it. That worked for me.

1

I had the same problem and while trying to find a solution I found many people suggesting to install the x86 version of Java which is stupid if you actually run a x64 operating system. Others suggested to try out MultiBit HD which isn't officially released yet, that's probably not a good idea either. Took me quite a while but I figured out how to get it working.

Seems like MultiBit is using IzPack and JSmooth and the second one has a problem to localize x64 version of Java on your system. To fix this set the JAVA_HOME environment as suggested above. https://confluence.atlassian.com/display/DOC/Setting+the+JAVA_HOME+Variable+in+Windows

1

Even better, set JAVA_HOME to the JDK path instead of the JRE path if you have the Java Development Kit installed. Otherwise you will have to edit the variable whenever Java JRE updates.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.