1

I have been running raspberry PI with 4 Erupter modules connected to Pi Hub for 5 days with no problems. Yesterday I checked the modules and the idle lights were on and there was no mining. I restarted my raspberry, and now I am getting this error:

 [2014-04-10 20:23:13] Icarus Detect: Test failed at /dev/ttyUSB0: get 00000000,
 should: 000187a2
 [2014-04-10 20:23:13] Icarus Detect: Test failed at /dev/ttyUSB1: get 00000000,
 should: 000187a2
 [2014-04-10 20:23:14] Icarus Detect: Test failed at /dev/ttyUSB3: get 00000000,
 should: 000187a2

I am running the following command:

sudo ./cgminer-3.1.1/cgminer --config /home/pi/cgminer.conf -S /dev/ttyUSB0 -S /dev/ttyUSB1 -S /dev/ttyUSB2 -S /dev/ttyUSB3

If I connect and run the modules one by one there are no issues. When there are 3-4 I get errors. Those errors change each time I run it, so sometimes its 1 failing other times 2 etc. Also, I am getting this error:

[2014-04-10 20:33:04] Most likely you have input the wrong URL, forgotten to ad
d a port, or have not set up workers

Again, there have not been any changes to the configuration (that I am aware of). Any suggestions as to what might be causing this/ how to fix it?

Update

cgminer.conf 

"pools" : [
        {
                "url" : "http://api.bitcoin.cz:8332",
                "user" : "worker",
                "pass" : "pass"
        }
]
,
    "api-listen" : true,
    "api-port" : "4028",
    "expiry" : "120",
    "failover-only" : true,
    "log" : "5",
    "no-pool-disable" : true,
    "queue" : "2",
    "scan-time" : "60",
    "worktime" : true,
    "shares" : "0",
    "kernel-path" : "/usr/local/bin",
    "api-allow" : "0/0",
    "icarus-options" : "115200:1:1",
    "icarus-timing" : "3.0=100"
}

Erupters run from powered hub, and rpi is also running from wall charger.

1

This sounds like a power problem to your erupters most likely. Can you show me the config file or the options you are enabling? In particular, the -scan option.

Further, you might verify you have a powered USB hub and try using a powered USB port if available; it only takes a little power to run them, but a little power to stop them. I also power my rasp pi through a wall charger also, rather than powering it from the usb hub.

I have had much more success running BFGMiner with Erupters and Antminer U1 USB sticks with a Pi and usb hub to control (and using Minepeon on the rasp pi). The command to start BFGMiner and scan for erupters etc and create a log in case you do have problems is:

bfgminer –o [pool] –u [user] –p [password] –scan-serial erupter:all –icarus-options 115200:1:1 –icarus-timing 3.0=100 2>logfile.txt

  • I have updated the question. I am not sure what you mean by -scan option, is it the -S? I will be trying bfgminer shortly. – Giannis Apr 12 '14 at 20:31
  • Yes, -S is also scan, I just used the long form notation so you might understand what the options are for and what they do. You can type the commands that I stated above in BFGMiner, or their abbreviation. Furthermore, I don't think it's necessary to add any options after the --scan (-S), because I think the mining software will automatically set the values once it detects it from scanning. Simply running "bfgminer –o [pool] –u [user] –p [password] –scan-serial erupter:all" works for me, but you can also replace "all" with the device (Icarus, most likely) name and scan directly for it. – vnhyp0 Apr 12 '14 at 21:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.