-1

I have a rig with two GPU's set up in it. Both are ASUS and one is a R9 280x and the other is a HD 7790.

Both appear when I run the command:

sudo aticonfig --lsa

GPU 0: This is the HD 7790 GPU 1: This is the R9 280x

When I run the cgminer both GPU's appear and both are enabled but only the R9 280x is mining. The temperature doesn't appear for either of the GPU's.

I am running ubuntu 13.10 headless so I can't run two different cgminer scripts instances in two separate terminal windows as far as I know.

[EDIT]

My full cgminer command is as fillows:

./cgminer --scrypt -o stratum+tcp://my.pool.ip:xxxx -u myusername -p mypassword -I 19 -g 1 -w 256 --thread-concurrency 15232

And as mentioned this only mines on the R9 280x.

How do I get both GPU's to mine at the same time?

2

Have you tried the command -d 0,1, then setting your Thread Concurrency and Looup-gap and worksize for each device accordingly.

You need to tell CGMiner you have two GPUs and set the thread concurrency for them. For this, try a command like this: ./cgminer --scrypt -o stratum+tcp://my.pool.ip:xxxx -u myusername -p mypassword -d 0,1 -I 18,19 -g 1 -w 256 --thread-concurrency 8000,15232

You must specify values for both cards or it will try to use the same thread concurrency on both cards, which most likely was causing the 7790 to fail. I am unsure how to run more instances of CGMiner for multiple cards that wont cause conflicts and crash video cards.

You said that your 7790 is GPU 0, that's why I put the TC 8000,15232 (TC for 7790 first, then TC for R9). I also told it to start GPU 0 at intensity 18, as the Radeon 7000 series seems to run better at 18 than 19 in my experience.

If those TC settings don't work, try 8000,8192 perhaps and lowering intensity on both to 18, or even 17 while you get them started. Then once they are mining it is good to start to fine tune.

Also, I seem to remember that the SDK version that is suggested to use with R9s is not a version that works to mine with the Radeon 7000 series.

This is almost working except cgminer is now telling me that Number of OpenCL and ADL devices did not match. Could you give an example of teh --gpu-map setting?

Another option to try the --gpu-map setting also to make sure the devices are seen properly, as there are sometimes issues with 2 video cards and one monitor and other weird scenarios.

I think that it would be better for me to give you a link to read about the setting, as it would provide more information and examples. I also get the same error for Number of OpenCL and ADL devices not matching but my devices still mine to their full potential.

Here is the link: github.com/luke-jr/bfgminer/blob/bfgminer/README.GPU and the information is about 2/3 down starting with the header, "GPU DEVICE ISSUES and use of --gpu-map". An example of using the setting looks like this: "--gpu-map 2:1,1:2", which doesn't mean much without context, so I highly recommend reading that link.

  • I updated the question above to include my ./cgminer command that I used. Can I specify a different ./cgminer for each GPU? – motionpotion Apr 12 '14 at 11:15
  • 1
    You need to tell CGMiner you have two GPUs and set the thread concurrency for them. Try a command like this: ./cgminer --scrypt -o stratum+tcp://my.pool.ip:xxxx -u myusername -p mypassword -d 0,1 -I 18,19 -g 1 -w 256 --thread-concurrency 8000,15232 You must specify values for both cards or it will try to use the same thread concurrency on both cards, which most likely was causing the 7790 to fail. I am unsure how to run more instances of CGMiner for multiple cards that wont cause conflicts and crash video cards. – vnhyp0 Apr 12 '14 at 11:26
  • 1
    You said that your 7790 is GPU 0, that's why I put the TC 8000,15232 (TC for 7790 first, then TC for R9). I also told it to start GPU 0 at intensity 18, as the Radeon 7000 series seems to run better at 18 than 19 in my experience. Hope this helps out! – vnhyp0 Apr 12 '14 at 11:32
  • ok. I am learning. :) I will try these settings and see how if they work. Thanks for your help. – motionpotion Apr 12 '14 at 13:22
  • No problem, let me know how it works, and if those TC settings don't work, try 8000,8192 perhaps and lowering intensity on both to 18, or even 17 while you get them started. Then once they are mining it is good to start to fine tune. – vnhyp0 Apr 12 '14 at 13:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.