1

I have just switched over to mining with bfgminer from cgminer and I noticed that bfgminer displays the hashrate as Mh/s on my running version whereas cgminer displayed it as Kh/s.

My GPU is a R9 280x and the most I could every get out of it using cgminer was about 750 Kh/s.

But now using bfgminer it is saying that I am getting ~1.24 Gh/s but I know this is not possible with this card.

bfgminer hashrate

On my pool stats this is showing as 674 Kh/s which I think is more accurate consider I have only one GPU card.

  • 1
    Are you certain it you are telling the card to mine scrypt algorithm? That looks like the hash-rate for dblsha with that card. To make sure it is mining scrypt, make sure you have the argument, "--scrypt" in your starting command. – vnhyp0 Apr 16 '14 at 8:49
  • The command I enter to start bfgminer is as follows: sudo bfgminer -S opencl:auto --scrypt -o stratum+tcp://mining.usa.hypernova.pw:3333 -u username.worker -p pw -I 13 -g 2 --thread-concurrency 11200 --gpu-engine 1080 --gpu-memclock 1500 --temp-target 72 --auto-fan --gpu-fan 40-80 --temp-cutoff 90 --temp-overheat 85 – motionpotion Apr 16 '14 at 9:36
  • Perhaps trying "sudo bfgminer --scrypt -S opencl:auto -o..." might fix the problem, if for some reason it requires the scrypt option at the very beginning. Might be worth a try at least. – vnhyp0 Apr 16 '14 at 9:59
  • @vnhyp0 I tried running it that way too but there's no difference in the display. sudo bfgminer --scrypt -S opencl:auto -o stratum+tcp://mining.usa.hypernova.pw:3333 -u username.worker -p pw -I 13 -g 2 --thread-concurrency 11200 --gpu-engine 1080 --gpu-memclock 1500 --temp-target 72 --auto-fan --gpu-fan 40-80 --temp-cutoff 90 --temp-overheat 85 – motionpotion Apr 16 '14 at 11:27
  • I wonder if it must be a BFGMiner bug since it shows proper pool stats for the card, but looks like dblsha algorithm speed. – vnhyp0 Apr 16 '14 at 11:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.