2

Total newbie at bitcoin; long time Linux user.

kubuntu precise 64: My first attempt was just to download it (a slightly older version than the one from the ppa below), untar it and run the executable. That worked fine and it was downloading the data (block chain?). Then I played with some settings and it stopped downloading. I tried a bunch of things with no success.

Among other things, I tried encrypting my wallet and changing the network settings in bitcoin about the time things stopped working.

Then, I deleted the whole tarball, the expanded files, and the .bitcoin directory tree and installed from apt using the instructions at: Installing Bitcoin-Qt on Ubuntu

It still won't download anything. It says "No block source available ..." and debug.log ends with a ton of messages which say 2014-04-19 13:36:21 connect() to 192.168.1.2:8333 failed after select(): Connection refused.

I went into my Actiontec gateway and saw that a port forwarding rule had been created by uPnP for 192.168.1.2:8333 (that's my notebook address with the port added) that says TCP any -> 8333. I have other rules using this IP - without the port on the address - which forward ports 587, 995, 5192.

When I go to http://www.canyouseeme.org/ , it tells me port 5192 is open (I have another application using that port), but it says "connection refused" for 587, 995, and 8333.

Any clues as to what I'm doing wrong (or what I should be doing instead) would be appreciated.

I can't figure out why the original attempt was working and then stopped.

  • If 'env | grep proxy returns a value for socks_proxy try unset socks_proxy before executing bitcoin and see if it works. – George Kimionis Apr 19 '14 at 14:08
  • Ok, so you changed the network settings when it was working. Would it be too much to ask what settings you changed? – Greg Hewgill Apr 19 '14 at 22:05
  • @GregHewgill @George I don't use any proxy settings with my computer for anything else, so I tried to turn off the proxy setting in bitcoin. I also fooled around with opening ports 9050 and 8333 on my gateway. All of this was before I completely wiped my bitcoin install and reinstalled it with apt. env|grep proxy returned nothing. – Joe Apr 20 '14 at 17:03
  • Have you tried just using a lightweight client to see if that works. Just thought you could eliminate network issues if that worked. – T9b Apr 25 '14 at 11:15
  • It's still weird. I also installed Armory and it was able to read the blockchain (until I ran out of disk space :( ), It prompted me to install bitcoind (which may have been why bitcoin-qt was unhappy.) Now, bitcoin-qt works and Amory crashes. I'm working with the Armory folks to figure out why. – Joe Apr 27 '14 at 0:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.