4

I built a mining rig with 3 Radeon 6850 GPUs. When I run one miner (either Phoenix or m0mchil's poclbm) it reports a hash rate of a little over 200 Mhash/sec. When I fire up a second miner pointed at a different GPU, the hash rate of both miners is about half what the one running alone would get. When I fire up a third pointed at the last GPU, all three miners report an even lower hash rate, such that the total is around the 200 Mhash/sec that a solo miner would get.

Initially, I thought that the miners were ignoring the DEVICE=# argument and all using the same GPU. I posted a question seeking help in figuring out why they would do that. @Lodewijk's answer there clued me in to the fact that the miners are using separate GPUs and that there's a bottleneck elsewhere in the system.

So, my question is, what's the likely bottleneck?

I used the recommendations at the bitcoin.it wiki entry on Mining Rigs to pick out my hardware. I'm running on a Ubuntu 11.10 system, with an msi 890FXA-GD70 motherboard, 2GB Kingston 1333MHz DDR3 Non-ECC RAM, 80GB WD IDE Drive, and a 2.8Ghz AMD Semperon 145 processor. It's on a cable Internet connection with tons of bandwidth and I'm connecting to the Arsbitcoin mining pool.

  • You should consider asking this question on the forum - bitcointalk.org . There are more hardware savvy miners there that can help with your specific problem I think. – ThePiachu Jan 13 '12 at 8:18
  • Yeah, I thought about that originally, but I strongly prefer the SE Q&A format. This question has been posted here long enough now that I figured I'd give it a try and went and signed up for an account over there. And that's when I discovered that I need to prove I'm worthy to post a question in the appropriate forum. Blech! If anybody with access to the Hardware forum over there would be willing to post a link to this Q here, it would be appreciated. But if I'm forced to make 5 posts to the newbie forum just to prove that I know how to do so, I guarantee they'll quite snarky. – Jon Garvin Jan 13 '12 at 19:26
  • 1
    Yeah, the forum can be a bit restrictive at times. I posted your question on the appropriate subforum: bitcointalk.org/index.php?topic=58589.0 – ThePiachu Jan 13 '12 at 19:41
  • Thank you. Maybe that'll bring a few more people over to use SE. – Jon Garvin Jan 13 '12 at 19:47
  • Thing is, such specific questions would normally be considered "too localised" and closed here, that's what the forums are for in general. – ThePiachu Jan 13 '12 at 19:55
2

Did you check the CPU usage? You can use TOP on Ubuntu (sudo apt-get install top, if it's not default). If it's not capping out at 100% it's either the chipset or CPU bandwidth giving up. You can also check you regular memory, although I'm quite sure that isn't used in GPU mining.

Some things you can easily strike off are network and disk. Disk isn't used at all and network shouldn't cap out even on dialup.

If it is in fact chipset or CPU bandwidth you have two options: 1. Overclock. Focusing on FSB clock should improve everything. I'm quite sure you can't get a 300% increase though. 2. Build a different system. I daren't advice about this though.

  • I cannot believe that it never occurred to me to run top. I guess that's my senior moment of the month. Yup, with just one GPU mining top reports cpu usage at near 95% on system processes, not leaving any room to go when firing up another GPU. Oddly, this is the same CPU/Motherboard combo that is allegedly getting 2.1Ghash/s on a rig with three 6990's according to en.bitcoin.it/wiki/Mining_rig – Jon Garvin Jan 14 '12 at 22:24
  • Oh, and yes, I've confirmed that CPU mining is not occurring, so that's not why the CPU is maxed out. – Jon Garvin Jan 14 '12 at 22:30
  • 1
    I can only figure that the drivers don't offload work efficiently enough. If you could try with windows 7, which should be slower than optimum but have correct drivers, you'll have closure on whether or not it's the drivers. – Lodewijk Jan 16 '12 at 1:15
  • Seems that it's some combination of driver/sdk bugs. Booting linuxcoin from a thumb drive solved everything. Found some posts on bitcointalk.org that give me some direction on getting the right combination of drivers, sdk, etc. that I'll try later. But, the CPU was in fact the right answer to the originial question and top found that, so... check. – Jon Garvin Jan 20 '12 at 2:00
1

An ancient sysadmin technique is to evade a non-trivial bug rather than tackle it head-on.

Download cgminer and give it a try. Just one instance of the miner will support these cards, each of them can be individually overclocked and temperature-controlled.

It might be some weird spin-lock problem in AMD's software that's ruining your performance. Which driver and SDK version are you using, BTW? Which OS?

  • I've never tried cgminer before. Gave it a try and even though it doesn't appear to have solved my problem directly, I definitely prefer it over the others. As for your other questions, the SDK I installed was AMD-APP-SDK-v2.5. and it's running on Ubuntu 11.10. – Jon Garvin Jan 14 '12 at 22:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.