I installed Bitcoin Armory on Ubuntu 13.10. I get the following output when I try to run it:

root@cloud-server-07:/BitcoinArmory# python ArmoryQt.py
Loading Armory Engine:
   Armory Version:       0.91.1
   PyBtcWallet  Version: 1.35
Detected Operating system: Linux
   OS Variant            : ('Ubuntu', '13.10', 'saucy')
   User home-directory   : /root
   Satoshi BTC directory : /root/.bitcoin/
   Armory home dir       : /root/.armory/
   LevelDB directory     : /root/.armory/databases
   Armory settings file  : /root/.armory/ArmorySettings.txt
   Armory log file       : /root/.armory/armorylog.txt
   Do wallet checking    : True
ArmoryQt.py: cannot connect to X server

Does anyone have any idea why?

2 Answers 2


You should not run Armory as root. If you want to run armory as another user, pick a user other than root. You can use "sux" (which you can apt-get install) to become that new user.

  • Why should you not run armory as root?
    – Emre K.
    Jun 26, 2014 at 11:10

The installation went fine, but the last line ArmoryQt.py: cannot connect to X server is the error. Somehow the program cannot be shown in a window. When this happens in an ssh session, you need to relogin with the -X or -Y option. In your case, I think you have to look at this answer:

You need to allow the root user access to the X server:

xhost local:root

And point the command to the right DISPLAY:

 sudo DISPLAY=$DISPLAY gedit /etc/profile
  • I'm connecting to this machine through SSH. 'xhost local:root' returns 'xhost: unable to open display ""'
    – Emre K.
    Jun 5, 2014 at 12:07
  • I'm actually trying to run armory as daemon and use JSON-RPC commands using armoryd.py. That gives the error: File "armoryd.py", line 55, in <module> from txjsonrpc.auth import wrapResource ImportError: No module named txjsonrpc.auth
    – Emre K.
    Jun 5, 2014 at 12:12
  • Hmm, are you sshing with the -X or -Y option?Otherwise you'll never be able to open a display.
    – Mathias711
    Jun 5, 2014 at 12:19
  • Isn't txjsonrpc needed for Armory? Im not into this material, but from what I read in the past couple of minutes I think it is. From there the txjsonrpc.auth you're missing should be added, and that error be resolved
    – Mathias711
    Jun 5, 2014 at 12:20
  • Yes true. It seems I need to install txjsonrpc. Can't figure out how to get it though. Thanks a lot btw
    – Emre K.
    Jun 5, 2014 at 12:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.