0

I'm having trouble getting my Zeusminer Blizzard running; neither cgminer nor BFGminer detect it. Here are the results of lsusb:

Bus 001 Device 025: ID 10c4:ea60 Cygnal Integrated Products, Inc. CP210x UART Bridge / myAVR mySmartUSB light
[...] 

bfgminer -d? -D says this. The relevant line, I think, is

 [2014-07-15 09:33:03] lowlevel_scan: Found usb device at usb:001:025 (path=(null), vid=10c4, pid=ea60, manuf=Silicon Labs, prod=CP2102 USB to UART Bridge Controller, serial=0001)

And here is how I start up BFG: /home/me/crypto/bfgminer/bfgminer -S zeus:/dev/ttyUSB25 --set zeus:clock=340 --o stratum+tcp://mypool.com:6030 -u myuser -p mypass

I've also tried -S zeus:auto, /dev/tty25 and /dev/ttyS25 (because both of those files exist in my /dev directory, so I gave them a try), and detecting devices from the menu in BFG (which has actually worked for me in the past, but alas not this time). I made sure to compile it with the --enable-scrypt option.

I've determined that it's Device 025 by unplugging it and plugging it back in.

Any help or hints, anything to try, would be greatly appreciated; I'm eager to get my Zeusminer working and have been banging my head against a wall for a day trying. I also tried the version of cgminer that comes with it, with the same results.

Update: I'm using Bfgminer 4.4.0, which is the most recent, compiled from github yesterday. I compiled with --enable-script.

Update2: Using the new command line arguments from Mathias711 below, the Zeusminer is finally detected, but throws errors and does not hash. The errors are:

ZUS 0aa: Comms error (werr=1)
 [2014-07-15 22:52:40] ZUS 0aa: Failed to reopen on /dev/ttyUSB0
 [2014-07-15 22:52:40] ZUS 0aa failure, attempting to reinitialize
 [2014-07-15 22:52:40] ZUS 0aa: Failed to reopen on /dev/ttyUSB0
 [2014-07-15 22:52:40] ZUS 0aa failure, disabling!
 [2014-07-15 22:52:40] ZUS 0aa being disabled

Those are using /home/me/crypto/bfgminer/bfgminer --scrypt -S zeusminer:all --set zeusminer:clock=340 -o stratum+tcp://myreu.nut2pools.com:6030 -u me -p pass It actually does hash a tiny bit, but I can't tell if that's a display error or what.

Update 3: Solved!

  1. The first problem was the command I was starting it with. "zeus" is no longer a valid option; in newer versions of BFG, it's "zeusminer". The final, working command in BFGminer 4.4.1 is /home/me/crypto/bfgminer/bfgminer --scrypt -S zeusminer:all --set zeusminer:clock=340 -o stratum+tcp://myreu.nut2pools.com:6030 -u me -p pass.

  2. The second issue, the one that caused the list of errors above, was a bad power supply. I decided to try it with a power supply that I knew was good, and as soon as I plugged it in the errors stopped and it began to hash. It's pretty scary that it was running for hours with a bad power supply; I've had that ruin entire computers.

I've read reports of other people getting bad power supplies with their Blizzards, too. Combined with my own experiences on this one, if I ever buy another, the power supply is going right in the trash.

1

There are a few things that might be going wrong.

First, are you sure that your user has rights to read and write the serial port? (There are plenty of tutorials online about how to do this.) You can check if that is the problem by running (temporarily) as root. If it starts to work, then you can go back and sort out how to give your user rights to the serial port.

Second, your command line looks like it may be wrong. I say "may" because it depends on whose version of bfgminer you are running with. My recommendation is to get the official one from the Github site and build it. Assuming that is the one you have, then you need to call the miners zeusminer instead of just zeus. You should also be using -o to define your pool, not --set.

Third, you need to tell bfgminer to operate in scrypt mode, or it will default to SHA256 mode. This is done by adding the --scrypt command line option.

Try this command line :

sudo /home/me/crypto/bfgminer/bfgminer --scrypt -S zeusminer:all --set zeusminer:clock=340 -o stratum+tcp://mypool.com:6030 -u myuser -p mypass

I just fired up two Blizzard using a command line very similar to this. (The only difference is I use the -O option to pass my user name and password together.)

  • Not working yet but I think it's close! Using your command line it sees the Zeusminer, but throws a bunch of errors. I will edit the original post so that they're readable; can't format in the mini comment box. To answer some of your questions: I always run bfgminer as root because I have permissions issues otherwise. using --set to define the pool was a type; I was using -o. – felwithe Jul 16 '14 at 3:03
1

I could only get one of my blizzards to be recognized, until I changed the parameters I was giving to bfgminer. I was using

sudo bfgminer --scrypt -S zeusminer:all --set zeusminer:clock=340 -o stratum+tcp://us.clevermining.com:3333 -u 1Ng5RswjvFwM4bLE4wXLYHvZHTmN9v6WAD -p pass

but I changed that to

sudo bfgminer --scrypt -S zeusminer:auto --set zeusminer:clock=340 -o stratum+tcp://us.clevermining.com:3333 -u 1Ng5RswjvFwM4bLE4wXLYHvZHTmN9v6WAD -p pass

(I changed all to auto.)

  • actually, i don't know why that worked that time. i've gone back to "all" and that works fine – Brent Kohler Mar 1 '17 at 1:05
0

I had the same issue.

Turns out my problem was my gridseed blades had hotplug=1 set which was interfering. Pointing each to the direct usb port fixed it

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.