1

Now I have installed bitcoin with config rpcssl=1, and I have tested the connection with a java application. Everything seemed OK.

Then I installed p2pool, and tried to connect to bitcoind (python2.7 run_p2pool.py), and I was faced with the following errors:

Testing bitcoind RPC connection to 'http://127.0.0.X:8332/' with username 'pool'...
2014-07-16 15:29:25.036426 > Error while checking Bitcoin connection:
2014-07-16 15:29:25.036567 > Traceback (most recent call last):
2014-07-16 15:29:25.036770 > Failure: twisted.internet.error.ConnectionDone: Connection was closed cleanly.

Then I modified the bitcoin.conf and erased the rpcssl=1 item, restarted bitcoind. Then I run the command, connecting to bitcoind successfully.

So I wonder how to config p2pool so that it can connect to bitcoind with HTTPS?

1

For using SSL with Bitcoin follow these instructions: https://en.bitcoin.it/wiki/Enabling_SSL_on_original_client_daemon

Maybe your RPC Connection String have connection type "HTTP"

connection-type = "http" 

Change http to https

  • where to change http to https in P2Pool? I couldn't find this option in P2Pool's run_p2pool.py arguments. – DISSIDIA-嘎嘎 Jul 17 '14 at 8:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.