I hadn't started/used my Bitcoin client for ages. Now, whenever I start the client, it is downloading block 135407 and does not progress past it.

What can I do?

  • See bitcoin.stackexchange.com/questions/2914 for some things to try. Commented Feb 20, 2012 at 9:06
  • What version of the client? Commented Feb 20, 2012 at 9:46
  • thanks. I did try things mentioned in the other answers. I posted an answer to this question. @StephenGornick: I am using the latest 0.5.2 client.
    – Patrick
    Commented Feb 20, 2012 at 10:18

4 Answers 4


I had this happen to me once. It was apparently caused by an incompatible peer node.

  1. Delete $HOME/.bitcoin/peers.dat
  2. Restart bitcoind

Afterwards, new compatible peers will be found, and hopefully, you'll start processing blocks as expected again.


Okay, based on the comments I have tried a couple of things but in the end only the following worked:

  1. Close Bitcoin client
  2. Backup files from %APPDATA%\Bitcoin
  3. Optional:Download Block chains from: http://sourceforge.net/projects/bitcoin/files/Bitcoin/blockchain/ to prevent lengthy initial download (Warning: the link advises against doing this if you have transactions in your wallet).
  4. Start Bitcoin client with the -rescan option from command line.

After that the client started downloading blockchains again. This worked for me. Not sure if this will work for everyone.


I had a similar problem, but the -rescan option didn’t help.

In my case, there were a lot of lines referring to orphan blocks in my debug.log file (not 100 % sure it’s related but it may):

2014-08-18 20:52:57 ProcessBlock: ORPHAN BLOCK 0, prev=00000000000000001132f6ac32387e51960e3154b2ad4420bdeb64d77999388f
2014-08-18 20:54:00 ProcessBlock: ORPHAN BLOCK 1, prev=00000000000000000e9926124cabed78be0ae8bab22fb20acc643e94749120f8
2014-08-18 20:56:37 ProcessBlock: ORPHAN BLOCK 2, prev=00000000000000001b3f790fc107051c17702d305b08a3ae6325f40ecf44eae9

Finally, I tried to restart the client with the -reindex option which fixed my problem (but took 100 % of my CPU usage for several hours while reprocessing the blockchain).

So if the rescan option don’t work, don’t give up, try the reindex option!


You should update your bitcoin software. Old bitcoin versions are not supported.

Look here: https://bitcointalk.org/index.php?topic=55852.0

  • It's true that regularly upgrading is encouraged, but all clients since 0.2.10 have supported to switch that happened on Februari 20th. Commented Feb 20, 2012 at 16:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.