I'm running OSX 10.7 and the newest version of Bitcoin-Qt. I put Bitcoin-Qt on my desktop, and found an old wallet.dat that was saved on a USB. I 'opened with' Bitcoin-qt, saw my balance, and tried a transaction before the most recent block was downloaded.

Now, after the entire blockchain has been downloaded, I see that my transaction is 0/unconfirmed. It's been a couple of days now.

In an attempt to get to the bottom of this, I read that it's best to find the bitoin folder in Application Data/Bitcoin, however there is no Bitcoin folder in application data. I've tried deleting the bitcoin client and downloading a new one, but the freshly downloaded bitcoin client is still using the wallet.dat from the USB stick. (the USB is not connected).

My question is, how do I find the bitcoin folder on Lion, so I can start over. I know not to delete the wallet.dat file when I do find it...

Oh, I've enabled my mac to see all hidden folders, just in case.

  • 1
    Can you see your transaction at blockexplorer.com ? – Thilo Mar 3 '12 at 10:29

The standard command-line client keeps it in ~/Library/Application Support/Bitcoin, at least on 10.6.

I don't know about bitcoin-qt, but some very broken applications keep the data inside the .app itself (right click, "show package contents").

Another typical unix configuration spot is ~/.program_name.

  • 1
    I am using bitcoin-qt (on 10.6.8), and the wallet is in ~/Library/Application Support/Bitcoin as well. – Thilo Mar 3 '12 at 10:30

The most important thing in your question was that you mentioned that you sent a transaction before all the blocks were downloaded, and now it is stuck at 0/Unconfirmed: This is completely normal.

The client will not send a transaction until it is reasonably up to date, and it may take up to another 24 hours after the blockchain is done downloading before it will attempt resending the transaction (although it may just verify and send the transaction on finishing the blockchain right away).


According to this answer the Bitcoin folder isn't visible inside Application Support unless you do some workaround.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.