I made this transaction more than 24 hours ago, and it still has no confirmations at all.

What should I do? This transaction was created by the mobile Blockchain.info wallet. At the time, it didn't warn me that transaction was problematic. However, I later noticed that one of the outputs of transaction is dust, using Blockchain.info's block explorer.

Any suggestions how to solve this issue?

  • Was it the Android or iOS mobile wallet?
    – morsecoder
    Commented Nov 18, 2014 at 15:37
  • @StephenM347 Android, old version
    – Arsenius
    Commented Nov 19, 2014 at 16:09
  • Have you tried upgrading and see if the problem persists? You could send an exact amount that would make a dust output to test, like I described in my answer.
    – morsecoder
    Commented Nov 19, 2014 at 16:42

3 Answers 3


In case you are interested as to the cause of this problem, I believe this is due to a 'bug' (of sorts) in the wallet you were using, in which the wallet software doesn't check to make sure it's not generating dust outputs.

Let's say you have a single 1.0 BTC UTXO (unspent transaction output) which is available for spending, and you want to send 0.99989999 BTC (slightly less than 1.0 BTC - default fee 0.0001 BTC). Then in this case, if that is the only UTXO that you have, then you cannot actually send the exact amount you requested and expect it to get confirmed in time.

      0.99989999  (Amount sent)
1.0 - 0.00000001  (Change)
      0.0001      (Miner fee)

You should be able to do this, since you have enough to fund the amount and pay for the fee, but the problem is that the transaction will also usually make a dust output (an output of less than 5460 satoshis). One solution is to just automatically give the extra dust to the person you are sending to. Another is to give it to the miners (by not claiming it in any of the outputs). A better solution is to use another UTXO that you own and be able to make a refund UTXO which is not dust, but this is not always possible.

In all of these solutions, no dust outputs are created. But if the wallet software just makes the transaction the usual way and give the leftover change back to yourself without checking to make sure that it's not dust, then what you saw happens and your transaction is not mined and then is eventually thrown out when it becomes old enough.

It's pretty unlikely that this bug would even be apparent in a particular transaction (about a 1 in 18,315 chance), but obviously not impossible, since you had this problem! Probably blockchain.info will apply the fix if enough people complain about it.


Looks to me like the transaction has failed, it's probably back in your original address after timing-out.

I've had the same problem you describe before, when including a fee of 0.0001 or even 0.00001 you shouldn't have any problems with a little bit of dust.

  • Yes indeed btc back to original address.
    – Arsenius
    Commented Nov 16, 2014 at 9:13

Problem is solved itself. Transaction has been canceled in the network and btc became available in the wallet.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.