5

Version 0.6 introduced automatic client localizations. Personally, I hate using programs in Hebrew, and prefer English, but the client didn't ask for my preferences on this matter and just switched to Hebrew.

How can I change the interface language back to English?

  • 1
    Sorry for that. – Meni Rosenfeld Apr 3 '12 at 14:25
  • PS localizations existed since at least the introduction of QT as standard in 0.5, but the Hebrew translation didn't yet exist at the time. – Meni Rosenfeld Apr 3 '12 at 14:26
3

Close the Bitcoin client and add this line:

lang=en

On a line by itself to the end of the file:

C:\Users\YourUserName\AppData\Roaming\Bitcoin\bitcoin.conf

(Replace "YourUserName" with your windows user name.)

Now restart the Bitcoin client. Done!

4

EDIT: The correct solution was provided by Matt Corallo but was somewhy deleted. Use the command line argument -lang=en_US.

As far as I know, QT chooses which language to use based on the OS settings. So I think the first thing to try is to configure your OS not to use a Hebrew interface.

If that fails, you should try to figure out how to disable localization in QT circles, since bitcoin-qt's localization inherits completely from QT.

If all else fails, you can recompile without the language in question.

  • My OS is not Hebrew, obviously. We need a setting for this. – ripper234 Apr 4 '12 at 6:27
  • 1
    @ripper234: Just as clearly, something in your OS is configured for Hebrew/Israel, otherwise bitcoin-qt would not use Hebrew. I don't know if this can be changed without side effects, but the research in Chris Moore's answer could be useful. Anyway, you can force a particular language with bitcoin-qt's -lang parameter. – Meni Rosenfeld Apr 4 '12 at 10:07
  • 1
    I did some more testing. On Windows, the default language is controlled by the dates format. I've been using US format so far (didn't bother to change it), but when I switch to Israel bitcoin-qt defaults to Hebrew. This is consistent with Chris's observations on Linux. I reverted to US, but while I'm at it, I switched just the day/month order to the Israel standard. – Meni Rosenfeld Apr 4 '12 at 12:22
  • I have no idea why Matt Corallo's answer was deleted. I have undeleted it so that people may give credit to what seems to be the correct answer. – D.H. - bitcoin.se Apr 8 '12 at 17:46
2

Start bitcoin with the -lang option ie bitcoin-qt -lang=en_US

1

I experimented a little in Linux to see what environment variables were affecting the choice of language:

$ env | grep -e LANG -e LC_ALL
LC_ALL=en_CA.UTF-8
LANG=en_CA.UTF-8
LANGUAGE=en_CA:en
$ LANG=de_DE ./bitcoin-qt --help 2>&1 | tail -1
  -?                 This help message
$ unset LC_ALL
$ LANG=de_DE ./bitcoin-qt --help 2>&1 | tail -1
  -?                 Dieser Hilfetext
$ LC_ALL=C LANG=de_DE ./bitcoin-qt --help 2>&1 | tail -1
  -?                 This help message
$ LANG=de_DE.UTF8 ./bitcoin-qt --help 2>&1 | tail -1
  -?                 Dieser Hilfetext
$ LANG=en_US.UTF8 ./bitcoin-qt --help 2>&1 | tail -1
  -?                 This help message

So it seems that making sure LC_ALL isn't set, and having an environment variable LANG=en_US.UTF8 will cause it to use English.

Alternatively, set LC_ALL=en_US.UTF8, but then everything will be USA-ish - you'll see American date formats, dots instead of commas for decimal points, etc.

The last time I used Windows you could set environment variables by going to the Control Panel, opening the System control, going to the Advanced tab, and clicking on Environment Variables. I don't know if that's changed in recent years though.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.