1

How do I get the Bitmain U3 running on Linux?

I'm using Ubuntu Server 11.

I have downloaded the bitmain branch of cgminer and compiled it to using CFLAGS="-O2 -Wall -march=native" ./configure --enable-bmsc

I have also downlaoded the official 4.9.0 and used CFLAGS="-O2 -Wall -march=native" ./configure --enable-icarus` as described in the text for U3

I do a lsusb and it shows this:

lsusb output

cgminer just does this

enter image description here

Is there anything that I missed? I read that its supposed to pick up the U3 automatically with default settings, then I can over clock it a bit to get the 63ghs stable.

0

The original USB cable supplied was faulty?? After I plugged it into another USB port just above it started to kick in but went ZOMBIE after a few seconds with USB Communication error??

I took another USB cable from my old 10xErupter Mega hub. Plugged it direct into the motherboard USB slot and U3 (also shorter cable). cgminer started to do all kinds of weird settings until it settled down on AU3.

Using the official git, I compiled cgminer (This also works for Raspberry Pi)

CFLAGS="-O2 -Wall -march=native" ./configure --enable-icarus

NOTE: Since version 4.9.0 you should not need to use any au3 switches

After that I set cgminer to --au3-freq 238 --au3-volt 780 Allot of people say that when you go higher than 780 with the stock 6A power supply it melts in about 10 hours.

So when I get round to using my computer PSU I will clock these at 250/800 as recomended for best speed stability.

enter image description here

  • Everything described here was successful for my instalation Antminer U3 on Ubuntu 14.04. Thanks a lot! – user34263 Mar 26 '16 at 16:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.