I've compiled a bitcoin-qt v0.8.6 on osx 10.9. It successfully runs on developer machine from 'Finder' (as Bitcoin-Qt.app) and from terminal (as ./Bitcoin-Qt.app/Contents/MacOS/Bitcoin-Qt). I've copied it to another machine (also osx 10.9). And it doesn't starts from 'Finder', error message is "applications is damaged or does not contain the necessary libraries" (but continues run from terminal). Any ideas?

  • I'm a little confused. Do you mean it does work in terminal, or that it doesn't?
    – Nick ODell
    Commented Dec 22, 2014 at 17:19
  • @NickODell, It does work in terminal
    – Crocodilys
    Commented Dec 23, 2014 at 20:19

2 Answers 2


Well, I have a bad Executable file value in Info.plist file located in .app/Contents. I've changed it to Bitcoin-Qt and solved my problem.


There are a lot of things that could be wrong with doing it this way.

One show stopper will be the permissions. You will need to check that all the application files have the permissions needed to run on the other machine.

An application in OSX is just a folder that contains a number of resources and the executable files. To see these right-click and "show package contents".

Second thing you will need to check to is the data files. These reside in your user's library, and will contain the entire blockchain (that's if you've let Bitcoin-QT do it's stuff long enough to syncronise it) and some other useful stuff. But be careful - DO NOT COPY THIS if you are setting it up for someone other than yourself, because these files contain your private keys.

This can be found in Users/yourshortusername/Library/Application Support/Bitcoin/ it will be about 32Gb.

If you are going to copy these, make sure Bitcoin QT is not running on your machine to perform the copy, and you will also need to change permissions when you copy these files over.

But in any case, I have a question for you. Why didn't you just compile the code on the other machine?

  • compile the code on the other machine I think he's trying to create a binary he can distribute.
    – Nick ODell
    Commented Dec 22, 2014 at 17:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.