1

After I install my Bitcoin client (0.9.3 64 bit on Win7) I can run it one time without problems. It won’t start up a second time, though, and terminate with the following error:

EXCEPTION: N5boost12interprocess22interprocess_exceptionE
Access denied
E:\Program Files\Bitcoin\bitcoin-qt.exe in Runaway exception

I don't store my blockchain data in the standard AppData folder. I have, however, specified the correct -datadir in the bitcoin-qt shortcut. So this should not be the problem.

I dicovered that all my Bitcoin folders are partially read-only. When I uncheck the box, the read-only will automatically be restored, I just don't know why and by which routine. Might this be the problem?

So in order to be able to run the client I have to reinstall it every time I want to use it at the moment and then it will work once. Any ideas?

1

I'm not an expert on Windows, but I suspect your problem is caused by your anti-virus program. As widely reported, some griefers have placed virus signatures in the Bitcoin block chain.

These virus signatures can't actually harm your computer---the block chain is non-executable---but virus programs detect them and quarantine the files anyway. You may want to poke around your anti-virus program's settings and see if there's a way to exclude bitcoin-qt and its data directory from your scans.

Although it won't help you now, it might ease your mind to know that the Bitcoin Core developers are working on this issue. If I understand correctly, their plan is to optionally allow each Bitcoin Core user to store the block chain with a slightly different encoding[1] so that virus signatures in the block chain are uniquely obfuscated on each computer.

[1] For compsci geeks: they plan to allow XORing the block chain it by a bitstream unique to each instance.

  • Thank you for your answer. My AV seems to have no problem with the blockchain, however. I tried to scan the whole directory and excluded Bitcoin from the permanent protection (that checks files upon opening them). Unfortunately, none of this worked. The error message prompt that I receive also seems to come from either the Bitcoin Client or Windows itself but not from the AV. – Flo Jan 18 '15 at 16:58
  • @Flo I can confirm David's theory. I had a similar issue in the past with an AV. I had to uninstall it completely to get bitcoin-core working again. You should also check your computer for malicious software with this tool: microsoft.com/security/pc-security/malware-removal.aspx – George Kimionis Apr 18 '15 at 20:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.