2

I am new to bitcoin mining, but pretty good with technology as a whole. As a Father/Son project, I recently purchased a couple of USB LiteCoin Scrypt miners (I bought them here: http://www.aliexpress.com/item/free-shipping-hot-selling-litecoin-USB-miner-220kH-s-scrypt-miner-Litcoin-miner-send-out-in/2019121334.html ). These have some drivers on them - they came with the Miner and are Windows based (or so they seem) - but I am strictly a Mac / Pi user.

So, I need some help in determining how to connect these Miners to a Pi or a Mac.

Can someone help me? Many thanks in advance.....

  • I can't tell if these are miners or USB drives: Capacity: 8G U disk – Nick ODell Jan 22 '15 at 19:47
  • AH. I think they are a bit of both. They come with a 8GB built-in storage capability (which shows up on my Mac Finder as a couple of folders with some apps and drivers. The drivers are Silicon Lab - so I went to the web site here : silabs.com/products/mcu/Pages/USBtoUARTBridgeVCPDrivers.aspx and found the MAC version of the drivers (installed them) and still no luck. The device is a Miner by functions. The memory is a small add-on. Does this help? – RanduCandu Jan 23 '15 at 11:40
1

I think these might be rebranded ZeusMiner ASICs - LKETC doesn't appear to sell any scrypt miners below the 1MH/s range. Also, some of the reviews on that item say that they've had luck on linux with a fork of cgminer with ZeusMiner support.

There are two drivers you need. You need a driver for the USB-to-UART bridge, and a driver for the ASIC. The former is distributed with Raspbian, assuming the bridge is a Silicon Labs CP210x. (I think it is, based on the screenshots on that page.) The latter is usually distributed with your mining program of choice.

Possible fix

All instructions are intended for Debian/Ubuntu/Raspbian.

$ sudo apt-get install build-essential libtool autotools-dev autoconf git
$ git clone https://github.com/dmaxl/cgminer/ && cd cgminer
$ ./autogen.sh
$ ./configure --enable-scrypt --enable-zeus
$ make
$ ./cgminer

Troubleshooting (if that doesn't work)

When you plug it in, it should create the device /dev/ttyUSB1, and a device under /media or /mnt. You're interested in the first one.

You can get a list of devices that are plugged in with lsusb.

  • Hi, I have confirmed the drivers are Silicon Lab CP210x. I have downloaded the Mac versions from here : silabs.com/products/mcu/Pages/USBtoUARTBridgeVCPDrivers.aspx. I am going to try what you've typed out and see how it goes. Is there a preferred Pi Image that I should start with to accomplish this? I only have access to a NOOBS starter image, but I think I can figure out how to download and clone a new one (if you can point to one that is most appropriate). Many thanks @NickODell. – RanduCandu Jan 23 '15 at 11:44
  • HA, look what I found. aliexpress.com/item/…. This may not be rocket science, but perhaps it is helpful to you? The images show a step-by-step process for Windows. There is an app called LKController?? Do I need something like this for Pi / Mac to work? How very odd. – RanduCandu Jan 23 '15 at 11:49
1

I build a custom driver wich allow to run lketc usb miner with other scrypt miner (originaly this driver is a zeus clone, but if you use lketc and zeus at same time one of miner not works)

you can download source code here : http://github.com/wareck/cgminer-lketc

and for windows user: http://github.com/wareck/cgminer-lketc/releases/download/cgminer-dragon-win32/cgminer-lketc-win32.zip

wareck

0

Took me AWHILE to figure out how to make this cheap piece work with straight cgminer in linux...

First grab the cgminer version from https://github.com/dmaxl/cgminer/

After you configure it with --enable-scrypt and --enable-zeus...

sudo ./cgminer --scrypt --zeus-chips 1 --zeus-clock 200 -S /dev/ttyUSB0

Use lsusb to figure out what the USB # is and you can crank the clock from 200 - 300... maybe more... It'll get hot and need a fan, if you crank it up too much.

These LKETC USB miners are indeed using Zeus chips

0

I don't know if you already solved this, but I got 2 of the 144KH/S-280KH/S USB LiteCoin miners running on my Mac - El Capitan by doing the following:

Download, build and install dmaxl/cgminer:

./autogen.sh ./configure --scrypt --enable-zeus make

Find the USB sticks using:

ls /dev/ | grep SLAB cu.SLAB_USBtoUART cu.SLAB_USBtoUART20 tty.SLAB_USBtoUART tty.SLAB_USBtoUART20

I tried both the tty.SLAB_USB* and cu.SLAB_USB* devices, only the cu.SLAB_USB* seem to work. Make sure the switch is in the proper position on each USB stick (switches to the right)

Startup cgminer using the command: sudo ./cgminer --scrypt --zeus-chips 1 --zeus-clock 144 --zeus-nocheck-golden --url stratum+tcp://us.litecoinpool.org:3333 --user user --pass pass -S /dev/cu.SLAB_USBtoUART -S /dev/cu.SLAB_USBtoUART20

The output looks like:


cgminer version 4.3.5-scrypt.2 - Started: [2016-02-10 13:28:56]
--------------------------------------------------------------------------------
 (5s):204.8K (1m):3.534M (5m):13.58M (15m):7.466M (avg):201.5Kh/s
 A:400  R:0  HW:0  WU:110.0/m
 Connected to us.litecoinpool.org diff 16 with stratum as user p0six.2
 Block: bf5105cb...  Diff:53.7K  Started: [13:32:12]  Best share: 570
--------------------------------------------------------------------------------
 [U]SB management [P]ool management [S]ettings [D]isplay options [Q]uit
 0: ZUS cu.SLAB_USBt:    1 chips   144 MHz    | 98.30K / 98.29Kh/s WU:  0.0/m
 1: ZUS cu.SLAB_USBt:    1 chips   144 MHz    | 106.2K / 103.2Kh/s WU:110.0/m
--------------------------------------------------------------------------------
 [2016-02-10 13:28:55] Found Zeus at /dev/cu.SLAB_USBtoUART20, mark as 0
 [2016-02-10 13:28:55] ZUS0 opened on /dev/cu.SLAB_USBtoUART
 [2016-02-10 13:28:55] ZUS1 opened on /dev/cu.SLAB_USBtoUART20
 [2016-02-10 13:28:55] Probing for an alive pool
 [2016-02-10 13:28:55] Pool 0 difficulty changed to 1024
 [2016-02-10 13:28:56] Network diff set to 53.7K
 [2016-02-10 13:29:40] Pool 0 difficulty changed to 128
 [2016-02-10 13:29:40] Stratum from pool 0 requested work restart
 [2016-02-10 13:29:40] Stratum from pool 0 requested work restart
 [2016-02-10 13:29:55] Stratum from pool 0 requested work restart
 [2016-02-10 13:29:57] Stratum from pool 0 detected new block
 [2016-02-10 13:30:02] Stratum from pool 0 requested work restart
 [2016-02-10 13:30:19] Accepted 74e89353 Diff 561/128 ZUS 1
 [2016-02-10 13:30:30] Pool 0 difficulty changed to 16
 [2016-02-10 13:30:30] Stratum from pool 0 requested work restart
 [2016-02-10 13:30:36] Accepted 0f7528ed Diff 17/16 ZUS 1
 [2016-02-10 13:30:36] Accepted 0cd35843 Diff 20/16 ZUS 1
 [2016-02-10 13:30:37] Accepted 0e6b87d6 Diff 18/16 ZUS 1
 [2016-02-10 13:30:39] Accepted 0f759ff9 Diff 17/16 ZUS 1
 [2016-02-10 13:30:46] Accepted 077eb8cf Diff 34/16 ZUS 1
 [2016-02-10 13:30:47] Accepted 02072ca0 Diff 126/16 ZUS 1
 [2016-02-10 13:30:55] Stratum from pool 0 requested work restart
 [2016-02-10 13:31:00] Stratum from pool 0 requested work restart
 [2016-02-10 13:31:02] Accepted 72e164bb Diff 570/16 ZUS 1
 [2016-02-10 13:31:11] Stratum from pool 0 requested work restart
 [2016-02-10 13:31:13] Accepted 01064e29 Diff 250/16 ZUS 1
 [2016-02-10 13:31:24] Accepted 043989e0 Diff 61/16 ZUS 1
 [2016-02-10 13:31:30] Accepted 090f91cc Diff 28/16 ZUS 1
 [2016-02-10 13:31:31] Stratum from pool 0 requested work restart
 [2016-02-10 13:31:36] Accepted 0d552c6d Diff 19/16 ZUS 1
 [2016-02-10 13:31:38] Accepted 075f6dce Diff 35/16 ZUS 1
 [2016-02-10 13:31:54] Accepted 03582610 Diff 77/16 ZUS 1
 [2016-02-10 13:31:54] Accepted 03e27b84 Diff 66/16 ZUS 1
 [2016-02-10 13:31:59] Accepted 0ecb339a Diff 17/16 ZUS 1
 [2016-02-10 13:32:06] Accepted 0d200fb6 Diff 20/16 ZUS 1
 [2016-02-10 13:32:12] Stratum from pool 0 detected new block
 [2016-02-10 13:32:14] Stratum from pool 0 requested work restart
 [2016-02-10 13:32:17] Stratum from pool 0 requested work restart
 [2016-02-10 13:32:30] Accepted 01433148 Diff 203/16 ZUS 1

You can adjust the clock frequency, provided you have a fan.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.