3

The total blockcount on my machine is not increasing. I have tried doing a bitcoind -reindex -daemon, but it didn't ultimately increase the number of blocks.

Attaching machine and bitciond information below.

Operating System:

my_machine ~ $ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.04.1 LTS
Release:    14.04
Codename:   trusty

Bitcoin daemon:

my_machine ~ $ bitcoind getinfo
{
    "version" : 90300,
    "protocolversion" : 70002,
    "walletversion" : 60000,
    "balance" : 0.00000000,
    "blocks" : 322082,
    "timeoffset" : 1,
    "connections" : 8,
    "proxy" : "",
    "difficulty" : 29829733124.04041672,
    "testnet" : false,
    "keypoololdest" : 1422374797,
    "keypoolsize" : 100,
    "unlocked_until" : 0,
    "paytxfee" : 0.00000000,
    "relayfee" : 0.00001000,
    "errors" : "Warning: The network does not appear to fully agree! Some miners appear to be experiencing issues."
}

UPDATE: Per the issue explained here: http://sourceforge.net/p/bitcoin/mailman/message/33222029/, it appears that OpenSSL is the issue. I tried to rectify the latest block being stuck at 322082 by doing the following

git clone -b 0.9 https://github.com/bitcoin/bitcoin.git bitcoin-0.9
cd bitcoin-0.9
./autogen.sh
cd src
./configure
./configure --with-incompatible-bdb
make
make check
stop bitcoind
bitcoind -daemon -server -reindex

I then waited for the reindex to finish but I still have the same problem. Am I doing something wrong? How can I test that I have the right version of OpenSSL required?

  • What does the debug.log say? You may locate it in the same folder as wallet.dat - %APPDATA%\Bitcoin – Marek Feb 1 '15 at 23:10
  • db.log posted here: pastebin.com/Bcw66V5C – Idr Feb 2 '15 at 17:26
2

According to this GitHub discussion it turns out that the problem is caused by OpenSSL moving to 0.9.4.0 binaries should resolve your issue.

Gregory Maxwell

The incompatibility is due to the OpenSSL update changing the behavior of ECDSA validation to reject any signature which is not encoded in a very rigid manner. This was a result of OpenSSL's change for CVE-2014-8275 "Certificate fingerprints can be modified".

While for most applications it is generally acceptable to eagerly reject some signatures, Bitcoin is a consensus system where all participants must generally agree on the exact validity or invalidity of the input data. In a sense, consistency is more important than "correctness".

0

My answer pointed doubt at the "9.4 SHOULD resolve your issue" answer above. That appears to have been suggested by someone who hasn't actually tried it. I, however, have tried it... I have the the same OS version and the same problem as the OP. He didn't mention changing openssl, so probably has the same one as me, too (as supplied/updated with 14.04). 0.9.4 didn't work. I find it a bit odd that you delete an answer saying that a suggested fix doesn't work, but leave the unverified fix up. I'd love to find a real answer too, it takes me nearly two weeks to reindex and find out that a suggested fix doesn't work, maybe other people would like to know it didn't work on another 14.04 system? No doubt this will get deleted too as it isn't answer. I have the patched 1.01f

  • pictsidhe, I believe your answer was removed because it recommended using a version of openssl that is vulnerable to the heartbleed bug (OpenSSL 1.0.1 through 1.0.1f are vulnerable). In addition, while I agree with you that it is valuable information to know if a proposed solution doesn't work, it would be better if you put a comment on the previous answer rather than submitting in another answer to the question. – morsecoder Mar 15 '15 at 15:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.