0

I run bitcoind on AWS on Ubuntu. The machine has 4Gb of memory and free shows some of it remains free. Enough disk space too.

Yet, I have to manually restart bitcoind quite often, because sending JSON-RPC requests returns a timeout error. That is, at first they do work, but then they don't. No matter what kind of request.

Has anyone ever come across this? Why does it happen? Does anybody have a plausible theory?

  • What version of bitcoind are you running? Also, is the blockchain caught up? (You can tell what block you're on by running bitcoind getinfo or bitcoin-cli getinfo respectively) – JohnDvorak Feb 20 '15 at 14:27
  • Does increasing rpcthreads cause the problem to stop? – Nick ODell Feb 20 '15 at 21:21
  • Some HTTP client software does not deal with the persistent connection feature that bitcoind offer. Persistant connections are off by default in 0.10 again, but can be re-enabled with -rpckeepalive. – Pieter Wuille Feb 20 '15 at 22:16
2
  1. Upgrade to the very latest stable version. We saw alot less memory leakage with .10 on ubuntu
  2. run a cron job to restart it every night around 4:00 am est when there are fewest ransactions. This will cut down on memory leakage
  3. make sure your box has at least 4 gigs of ram and a 2 gig swap partition.
  4. give us some more info here. like linux distro, machine stats and what kind of rpc calls u often do.
0

I have observed that if the HTTP client sending the JSON-RPC request does not send a Connection: close header then the bitcoind RPC server stops responding after a number of calls.

  • Indeed, there seem to be some problems with certain clients and persistent connections. 0.10 disables persistent connections by default. – Pieter Wuille Apr 8 '15 at 18:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.