5

I am on Windows machine on a network that is closed for all incoming packets and outgoing packets only work for port 80.

In the network I have access to a Linux via SSH that is open for in and out access.

I want to run the wallet client Bitcoin-QT on the restricted Windows machine, I setup a tunnel using D9050 to the open Linux and then I told Bitcoin-QT that there is socks proxy on localhost port 9050.

The client runs and starts to show connections (which is doesn't show without the tunnel) but it doesn't start downloading the block chain :(

Help ?

  • i think i should have some process listening on 8332 on the linux so that when other nodes try to contact me they will reach something ... but i am not sure – thedrs May 13 '12 at 15:17
2

The easiest way to make this work would be to install cygwin on your windows machine, specifically ssh client package.

Then from a cygwin shell, run ssh -D 8080 user@linuxHost.

Now you can point the qt client to localhost:8080 as the socks proxy.

  • is this different from setting up a tunnel using putty like i mentioned above ? – thedrs May 15 '12 at 5:30
  • It seems like it works if one changes socks protocol to 4 in Bitcoin-QT. – dma_k Apr 10 '15 at 14:05
2

You can use Putty to create a socks proxy too:

http://www.virtualroadside.com/blog/index.php/2007/04/12/dynamic-socks-proxy-using-putty/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.