0

Good Day!

I am trying to compile the Particle-Qt Client on Ubuntu 15.04 Vivid Velvet using GCC 5.0 & libboost1.55

So my system is throwing errors, these are the following:

While executing qmake, I am getting this:

Project MESSAGE: Building with UPNP support
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Removed plural forms as the target language has less forms.
If this sounds wrong, possibly the target language is not set or recognized.
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Removed plural forms as the target language has less forms.
If this sounds wrong, possibly the target language is not set or recognized.
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element
Warning: ignoring <defaultcodec> element

And When Executing Make I am getting:

cd /media/red_gene/DeOxyRibose/Particle_REACQ/src/leveldb && CC=gcc CXX=g++ make OPT="-m64 -pipe -fstack-protector-all -D_FORTIFY_SOURCE=2 -O2" libleveldb.a libmemenv.a
make[1]: Entering directory '/media/red_gene/DeOxyRibose/Particle_REACQ/src/leveldb'
make[1]: 'libleveldb.a' is up to date.
make[1]: 'libmemenv.a' is up to date.
make[1]: Leaving directory '/media/red_gene/DeOxyRibose/Particle_REACQ/src/leveldb'
cd /media/red_gene/DeOxyRibose/Particle_REACQ; /bin/sh share/genbuild.sh /media/red_gene/DeOxyRibose/Particle_REACQ/build/build.h
fatal: Not a git repository (or any parent up to mount point /media/red_gene/DeOxyRibose)
Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set).
g++ -c -m64 -pipe -fstack-protector-all -D_FORTIFY_SOURCE=2 -O2 -D_REENTRANT -fdiagnostics-show-option -Wall -Wextra -Wformat -Wformat-security -Wno-unused-parameter -Wstack-protector -fPIE -DQT_GUI -DBOOST_THREAD_USE_LIB -DBOOST_SPIRIT_THREADSAFE -DUSE_IPV6=1 -DHAVE_BUILD_INFO -DLINUX -D_FILE_OFFSET_BITS=64 -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -Isrc -Isrc/json -Isrc/qt -Isrc/leveldb/include -Isrc/leveldb/helpers -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -Ibuild -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -o build/bitcoin.o src/qt/bitcoin.cpp
src/qt/bitcoin.cpp:5:24: fatal error: QApplication: No such file or directory
compilation terminated.
Makefile:1106: recipe for target 'build/bitcoin.o' failed
make: *** [build/bitcoin.o] Error 1
2

Problem is here:

QApplication: No such file or directory

You might not have QT development files installed.

If using debian / ubuntu try:

apt-get install libqt4-dev
  • Had to remove qt5-qmake and replace with qt4-qmake! – DeOxyRibose Acid Mar 27 '15 at 18:51
  • Had to remove qt5-qmake and replace with qt4-qmake! -> how to do this? – creator Apr 13 '18 at 4:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.