Running Armory ( on Win7 x64 with the following flags:

"C:\Program Files (x86)\Armory\ArmoryQt.exe" --testnet --datadir=d:\data\armory\testnet3 --satoshi-datadir="d:\data\bitcoincore" --rpcport=8332 --debug --netlog --mtdebug --logfile=d:\data\armory

You'll find the log file throws a recurring error...

    -WARN  - 1427685617: (..\Blockchain.cpp:47) Somehow tried to add header that's already in map
    -WARN  - 1427685617: (..\Blockchain.cpp:48)     Header Hash: 00000000ad4e4c886567776c89e752614f251cca28b7dfcaf16867677ba0245a

FYI, those times/blocks correspond to the most recent blocks, as validated by Bitcoin-CLI.

It's worth noting that the "current block" field in Armory shows a block ~6000 old (stuck on 323060), and mouse hover says "last block received 1.5 minutes ago" (or something similar) and updates with the block discovery.

Bitcoincore (v0.10 btw) gives this screenshot (the top 2 Txs - TxID 706b60a90510e8db0186be5980819931127110e300ce10c5a5b3f5fb04667dc2 - are labelled ? however they are confirmed in Bitcoincore eventually)

I've tried numerous wallets instances in Armory, updating, ensuring the client is connected, using the rescanning/rebuilding database option, etc. EDIT: Rescanning the database has actually erased all record of the Txs in Armory

What is wrong here?


1 Answer 1


OK, I solved this by numerous trial and error CMDs. The problem lay in the Armory implementation, specifically, the --datadir flag.

The working CLI flags:

  • ARMORY: -qt.exe --testnet --datadir=d:\data\armory\testnet3 --satoshi-datadir=d:\data\bitcoincore --rpcport=8332
  • BITCOIN-QT: bitcoin-qt.exe -datadir="d:\data\bitcoincore" -testnet -rpcport=8332

Contradicting Armory's FAQ (in the FAQ itself) is the requirement to explicitly identify the testnet3 directory for the --data-dir flag (--data-dir==SOME\DIR\Armory\testnet3). If the testnet3 directory isn't identified, Armory confuses the mainnet blockchain data with the testnet chain data.

The bitcoin.conf contents were:


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.