3

I'm running bitcoind for a service that works with quite small user withdraws most of the time. Recently I noticed that instead of the standard 0.0001 tx fee from the recent past, it already charges up to 0.0008 for some transactions which I find expensive for this specific use case. (I read about that update to dynamic fees but then forgot about it)

getinfo gives "paytxfee" : 0.00000000" by the way. I haven't explicitly set the fee in bitcoin.conf

So, if one doesn't want to take advantage of the dynamic fee but set a fixed one - How is best to do it? Just "bitcoin-cli settxfee 0.0001" or in the .conf file? Would it actually be enforced or it will still disregard it in some cases? - if it actually works to set it as fixed, how do you think that would affect the confirmation time? Will 0.0001 be fairly enough for the time being to get in the very next block?

  • Can you give the txid of such a transaction, so we can see its details? One possibility is that the transaction is larger than 1 kb (the standard fee is btc 0.0001 per kb). – Nate Eldredge Apr 30 '15 at 18:16
  • Yes, here is one blockchain.info/tx/… This particular one is for bigger amount but still, since it's 1257 bytes should be able to be sent just fine for 0.0002 fee right? – CryptoPanda May 2 '15 at 12:55
1

First: remind settxfee is not a absolute fee per transaction. It's a fee per kilobyte.

Example:

  1. Alice sends 1BTC to Bob
  2. Alice has 11 times 0.1 BTC in her wallet (she received 11 times 0.1 BTC from different persons)
  3. Alice transaction will require all 11 x 0.1BTC inputs to create the 1BTC-to-Bob-transaction
  4. Therefore the transaction is bigger (in terms of bytesize) then if she would hold 1 x 1.1BTC in her wallet.

Bitcoin-Core will only accept transaction to it's mempool which contains the minimum fee.

0

Yes, if you use settxfee that overrides and it will use that set amount.

  • Should I set that in the .conf file or as bitcoin-cli command? – CryptoPanda May 4 '15 at 17:50
  • @CryptoPanda Personally I do it through RPC/bitcoin-cli as I don't restart my node(s) very often. – George May 5 '15 at 19:06
  • Ok I'll try that Does that way of setting it stays after restart? – CryptoPanda May 7 '15 at 11:00
  • @CryptoPanda No, I don't think it does. You could use the -maxtxfee=<amt> parameter on startup perhaps. – George May 8 '15 at 17:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.