0
root@srv [~/public_html/server/bin]# ./bitcoind -daemon

Bitcoin server starting

root@srv [~/public_html/server/bin]# sendto: Operation not permitted

What is the problem?

Also, bitcoind didn't download the blockchain in my linux centos server.

What is the reason?

1

Most likely SELinux.

~/public_html is not the correct place to store binaries or even the bitcoin data directory.

Put the binaries in ~/bin/

The data files should end up in ~/.bitcoin/ if you haven't changed the configuration. That should be okay.

If it still doesn't work you might need to run restorecon -R ~/bin to fix SELinux attributes.

|improve this answer|||||
  • root/public_html/server/bin/ here is my bitcoind . and data file is 'root/.bitcoin/ . what is the problem?? i run the command restorecon -R ~/bin. sitill same this.. pls give me some solution – Md Shahadat Hossain May 15 '15 at 12:16
  • 1
    public_html is for serving web pages, not for binaries. Put the bitcoin binaries in ~/bin/ . AFTER moving you may need to run restorecon. Also don't run bitcoin (or anything) as root, create a new user and run bitcoin as that user. Once you have it working you probably want to set it up as a systemd service, which is very simple. – Jannes May 15 '15 at 12:27
1

This is very likely to be a Firewall problem. The "sendto: operation not permitted" is the typical message you get from an iptables reject

i never run a full bitcoind myself but looking at the documentation you need port tcp:8333 inbound and , i guess, at least HTTP and HTTPS outbound ...

check your firewall with

iptables -L -n

if the firewall is running, just to confirm you might try to stop the firewall and see if it fixes your problem.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.