1

From Bitcoin Core's test directory (bitcoin/src/test), the executable test_bitcoin is supposed to run the unit tests. When I run test_bitcoin, however, I get:

replication requires locking support
Test setup error: std::runtime_error: CDBEnv::MakeMock : Error 22 opening database environment.

How can I run test_bitcoin? I installed Bitcoin from source.

Also:

I ran configure using the --with-incompatible-bdb flag.

  • Why don't you install the correct version of bdb? I have the correct .debs in this repository: github.com/nickodell/build_bitcoin Does that fix it? – Nick ODell May 17 '15 at 0:32
  • @NickODell When I run build.sh I get: dpkg: regarding .../libdb4.8-dev_4.8.24-1ubuntu1_i386.deb containing libdb4.8-dev: libdb5.3-dev conflicts with libdb4.8-dev libdb4.8-dev (version 4.8.24-1ubuntu1) is to be installed. – DJG May 18 '15 at 21:47
  • It's complaining that you already have a different version of libdb installed. – Nick ODell May 18 '15 at 21:49
  • 1
    @NickODell I got it to work by uninstalling libdb5.3. I also had to reinstall the 64 bit version of libdb4.8-dev due to some packaging problem, but now it is working. Thanks! Also: how should this be written up as an answer so that users can see that this question already has been answered? – DJG May 19 '15 at 0:44
1

Try installing the correct version of BerkleyDB. (4.8) I have the correct .debs in this repository:

http://github.com/nickodell/build_bitcoin

You may need to uninstall the newer version of libdb first.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.