3

I'm trying to run bfgminer on a Raspberry Pi but the zeusminer is not being recognized. When I run the command:

sudo bfgminer-5.1.0/bfgminer -S zeusminer:all -d? -D

I get:

 [2015-05-31 19:47:42] setrlimit: Soft fd limit not being changed from 1024 (FD_SETSIZE=1024; hard limit=4096)
 [2015-05-31 19:47:42] Started bfgminer 5.1.0
 [2015-05-31 19:47:42] lowlevel_scan: Found usb device at usb:001:007 (path=(null), vid=1c4f, pid=0002, manuf=SIGMACHIP, prod=USB Keyboard, serial=(null))
 [2015-05-31 19:47:42] lowlevel_scan: Found usb device at usb:001:006 (path=(null), vid=0403, pid=6001, manuf=FTDI, prod=FT232R USB UART, serial=AH02YA6E)
 [2015-05-31 19:47:42] lowlevel_scan: Found usb device at usb:001:005 (path=(null), vid=0bda, pid=8176, manuf=Realtek, prod=802.11n WLAN Adapter, serial=00e04c000001)
 [2015-05-31 19:47:42] lowlevel_scan: Found usb device at usb:001:004 (path=(null), vid=1a40, pid=0201, manuf=(null), prod=USB 2.0 Hub [MTT], serial=(null))
 [2015-05-31 19:47:42] lowlevel_scan: Found usb device at usb:001:003 (path=(null), vid=0424, pid=ec00, manuf=(null), prod=(null), serial=(null))
 [2015-05-31 19:47:42] lowlevel_scan: Found usb device at usb:001:001 (path=(null*), vid=1d6b, pid=0002, manuf=Linux 3.18.11-v7+ dwc_otg_hcd, prod=DWC OTG Controller, serial=bcm2708_usb)
 [2015-05-31 19:47:42] lowlevel_scan: Found usb device at usb:001:002 (path=(null), vid=0424, pid=9514, manuf=(null), prod=(null), serial=(null))
 [2015-05-31 19:47:42] lowlevel_scan: Found ft232r device at usb:001:006 (path=(null), vid=0403, pid=6001, manuf=FTDI, prod=FT232R USB UART, serial=AH02YA6E)
 [2015-05-31 19:47:42] lowlevel_scan: Found vcom device at dev_t:00bc000000000000 (path=/dev/ttyUSB0, vid=0000, pid=0000, manuf=FTDI, prod=FT232R USB UART, serial=AH02YA6E)
 [2015-05-31 19:47:42] Devices detected:
 [2015-05-31 19:47:42] Timers: Using clock_gettime(CLOCK_MONOTONIC_RAW)
 0 devices listed

Here is my command to try and get bfgminer to run:

sudo bfgminer-5.1.0/bfgminer --scrypt -o <pool> -u <user>.<worker> -p <password> -S zeusminer:/dev/ttyUSB0

I have tried running the -S flag with zeusminer:all, zeusminer:auto, and zeusminer:/dev/ttyUSB0.

Anyway any help would be greatly appreciated. Cheers

1

I'm running BFGminer 5.4.0 on a pi with two Zeusminers. Here is an example of my command that I run:

--scrypt -o stratum+tcp://pool:port -u username -p password -S zeusminer:/dev/ttyUSB0 --set zeusminer:clock=328 --set zeusminer:chips=6 -S zeusminer:/dev/ttyUSB1 --set zeusminer:clock=328 --set zeusminer:chips=6

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.