0

I set up bitcoind in Ubuntu 14.04 and I requested "getinfo", but returned HTTP 403 error "FORBIDDEN". I don't know why...

The environment is below.. ・Ubuntu is installed in Virtualbox and bitcoind is installed in the Ubuntu. ・The Host OS is Mac OS. ・The Host OS and the gest OS (Ubuntu) is connected host only adapter. (Host OS -> 10.0.2.2 Gest OS-> 192.168.33.33)

The bitcoin.conf is below

server=1

daemon=1

rpcallowip = 10.0.2.0/24

rpcuser=...

rpcpassword=...

rpcport=8332

txindex=1

keypool=100

From the browser, type "http://rpcuser:rpcpassword@192.168.33.33:8332/" but it gives "Forbidden"

Forthermore, i tried to use easybitcoin.php (https://github.com/aceat64/EasyBitcoin-PHP/blob/master/easybitcoin.php), but also the same like "HTTP_FORBIDDEN" "403"

Can you give me any advices?

  • Just to check, you are attempting http://user:password@192.168.33.33:8332/? – Anonymous Jun 14 '15 at 10:28
  • I tried , but the same, "Forbidden" – gano Jun 14 '15 at 11:03
2

Your rpcallowip setting is 10.0.2.0, but you listed 10.0.2.2 as the host OS's IP. That could be your issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.