1

i am attempting to upgrade my bitcoin client on debian wheezy. i have been following the docs for this version and i installed berkley db to ${BITCOIN_ROOT}/db4 as directed. that went fine, but now when i run ./configure it says the wrong version of berkleydb is installed:

checking whether C++ compiler accepts -fvisibility=hidden... yes
checking for Berkeley DB C++ headers... default
configure: error: Found Berkeley DB other than 4.8, required for portable wallets (--with-incompatible-bdb to ignore or --disable-wallet to disable wallet functionality)

i also found that autogen.sh does not exist in the bitcoin root dir so i was unable to run it as per the instructions.

i already have berkley db 5 installed:

$ dpkg -l | grep db5
ii  db5.1-util                                   5.1.29-5                           amd64        Berkeley v5.1 Database Utilities
ii  libdb5.1:amd64                               5.1.29-5                           amd64        Berkeley v5.1 Database Libraries [runtime]
ii  libdb5.1++:amd64                             5.1.29-5                           amd64        Berkeley v5.1 Database Libraries for C++ [runtime]
ii  libdb5.1++-dev                               5.1.29-5                           amd64        Berkeley v5.1 Database Libraries for C++ [development]
ii  libdb5.1-dev                                 5.1.29-5                           amd64        Berkeley v5.1 Database Libraries [development]
ii  libdb5.1-java                                5.1.29-5                           all          Berkeley v5.1 Database Libraries for Java
ii  libdb5.1-java-jni:amd64                      5.1.29-5                           amd64        Berkeley v5.1 Database Libraries for Java
ii  libkdb5-6:amd64                              1.10.1+dfsg-5+deb7u2               amd64        MIT Kerberos runtime libraries - Kerberos database
ii  libsybdb5:amd64                              0.91-2+deb7u1                      amd64        libraries for connecting to MS SQL and Sybase SQL servers

i don't want to remove db5 because other programs i rely on are using it:

 $ apt-cache rdepends db5.1-util
db5.1-util
Reverse Depends:
  subversion
    db5.1-util:i386
  subversion
    db5.1-util:i386
  libapache2-svn
    db5.1-util:i386

how can i get bitcoin to install with berkley db 4.8 when 5.1 is already installed elsewhere?

1

To allow compatibility of your wallet.dat file with other bitcoind installations, it's strongly recommended to use bdb 4.8.

Nevertheless, you can disable the db4.8 check by adding --with-incompatible-bdb during configure.

Better would be to manually install berkley db 4.8 in a isolated path and compile bitcoin-core with something similar to:

CPPFLAGS="$CPPFLAGS -I<your-bdb4.8-path>/include" LIBS="$LIBS -L<your-bdb4.8-path>/lib"

But this would probably require some makefile tweaking.

  • thanks! i have already installed berkley db 4.8 under ${BITCOIN_ROOT}/db4 (i followed the instructions in docs/builld-unix.md) i will try and compile bitcoin-core with the flags you suggest. if i have problems i will update the op. – mulllhausen Jun 17 '15 at 23:34
  • nope - its still coming up with the same errors when i run ./configure even with CPPFLAGS="$CPPFLAGS -I${BITCOIN_ROOT}/db4/include" and with LIBS="$LIBS -L${BITCOIN_ROOT}/db4/lib" – mulllhausen Jun 17 '15 at 23:52
  • If you have troubles using different include/ lib/ dirs for bdb you might try --with-incompatible-bdb and take the risk of not being able to use your wallet on bitcoin-core installations with bdb4.8. – Jonas Schnelli Jun 18 '15 at 6:55
  • ya i did that :) i can always import my private keys into other wallets so its no big problem for me – mulllhausen Jun 18 '15 at 8:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.