5

I have an Antminer u3 running on a raspberry pi using bfgminer. Its currently running at 47GH/s. Does anyone know if is possible to over clock it using BGFminer so that it will run at 55 - 60 GH/s?

if i cant do it using BFGminer is there another mining software i can do it in?

any suggestions would be welcome and would be appreciated:)

7

I set up my rasp pi b+ and U3 mining rig using the instructions in this forum post, with screen and cgminer.

The command relevant to over clocking the raspi that I used is the following:

sudo ./cgminer --bmsc-options 115200:0.57 -o POOL -u USERNAME -p PASSWORD --bmsc-voltage 0800 --bmsc-freq 1286

Those last two options (bmsc-voltage and bmsc-freq) are what over clocked the rasp pi. But I think I had to compile cgminer and configure it to include bmsc. Mine typically runs with a hash rate in the high 50's or low 60's, but maybe not quite 62-63 GH/s.

Also, I did try to push the U3 voltage and frequency higher by playing with the settings as detailed in the U3 manual. However, I could never get the U3 to run stably at settings any higher than what I gave above. I'm not sure if it makes a difference, but I'm actually running two U3's on the one rasp pi and cgminer instance.

Update: In the interest of providing a complete answer in one place, here's the full text from the linked forum post:

Run a fresh install of Raspbian using NOOBS, after the install type ifconfig and make a note of the IP address, so that you can remotely SSH into your Pi. Login via PuTTY with the default username/password, then raspi-config if you would like to change the hostname, default password and so on.

Now update the Pi: sudo apt-get update && sudo apt-get upgrade

Install dependencies:

sudo apt-get install libusb-1.0-0-dev libusb-1.0-0 libcurl4-openssl-dev libncurses5-dev libudev-dev screen libtool automake pkg-config libjansson-dev screen

Clone cgminer from here: git clone https://github.com/bitmaintech/cgminer

Install, configure and also enable bmsc options:

cd cgminer

sudo ./autogen.sh

export LIBCURL_CFLAGS=’-I/usr/include/curl’

sudo ./configure --enable-bmsc

sudo make

Test cgminer is working correctly by running the following (input your own pool, username and password):

sudo ./cgminer --bmsc-options 115200:0.57 -o POOL -u USERNAME -p PASSWORD --bmsc-voltage 0800 --bmsc-freq 1286

Type Q to exit cgminer...

Now, add cgminer to start automatically when the Pi is powered on and create a screen session:

sudo nano /etc/rc.local

Remember, Ctrl-X to exit, then type Y and press Enter to save changes. Add this just above exit 0, again enter your own pool, username and password:

cd /home/pi/cgminer

screen -dmS cgminer ./cgminer --bmsc-options 115200:0.57 -o POOL -u USERNAME -p PASSWORD --bmsc-voltage 0800 --bmsc-freq 1286

  • Thankyou, its now running at around 58gh/s :D – blobbymatt Jun 25 '15 at 6:20
  • no problem, glad I could help! – jfoo Jun 25 '15 at 6:27
2

I have 2 u3 antminers running on a raspberry pi b+ I could not get my u3 any faster until i used minera software,set to cgminer (offical) with command: --au3-volt 830 --au3-freq 250.0 In the settings menu it will run at 62-63 GH/s. you can download it hear http://getminera.com/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.