1

i have troubles with my system, using iotop i identified bitcoind as the source of problems. I am running bitcoind of bitcoin-0.10.0-linux32 and am using the RPC calls of bitcoind. My wallet file is 112 MB. My assumption is everytime an a new bitcoin address is created the whole wallet file is written to disk. In iotop i see that about ~110MB is written to disk regurarily by the bitcoind process. This is problematic for the system setup because it slows down other processings significantly. And this happens often, more than 1 time in a minute.

Can i do something about it?

Thank you Cahoiner

*************Edit*************

This problem still exists with current bitcoind 0.11.2.

I assembled statistics with inotifywatch. I watched the bitcoin directory for 4800 seconds, the results are: Wallet file modifications: 7585738 (ughh !!) Modifications in subdir chainstate: 1290930 (also high, pls lower this)

  • P.s. this is not about building up the local copy of the blockchain, that has been finished some time ago. – Cahoiner Jun 29 '15 at 4:22
  • My current solution: put wallet.dat to a ram-based filesystem (tmpfs), and copy from there to real filesystem with a cronjob. the system has now easy feeling, before moving wallet.dat to a ram-filesystem it was awfully laggy – Cahoiner Jun 30 '15 at 21:21
  • That sounds pretty dangerous. If your cronjob copies the file in the middle of a write, it could be stale or corrupted. (Not to mention what happens if your cronjob fails completely for some reason) And you could lose private keys if the PC crashes. I haven't checked the source code, but the reason bitcoin re-writes the whole file might well be that it first writes to a brand new file and then does an atomic rename operation. I wonder why it is doing that every minute though. Are you generating new keys every few seconds? If so, maybe you should increase your -keypool=x (default: 100) setting. – Jannes Jul 2 '15 at 11:30
  • I think a "move" was donefrequently. New address was not generated too frequently. Thanks for your response. – Cahoiner Aug 29 '15 at 6:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.