0

I have version 0.9.3 of bitcoind on my Ubuntu server and I want to upgrade to 0.10.1, I have nothing in my wallet. Does the blockchain 0.9.3 compatible with 0.10.1? Do I have anything to keep from version 0.9.3 ?

3

In the official release announcement here: https://bitcointalk.org/index.php?topic=1039713.msg11211433#msg11211433


Downgrade warning

Because release 0.10.0 and later makes use of headers-first synchronization and parallel block download (see further), the block files and databases are not backwards-compatible with pre-0.10 versions of Bitcoin Core or other software*


So upgrading works fine, but if you later decide to downgrade the block and database files won't be compatible.

1

It should be forward compatible, but making backups of your wallet is always recommended.

Once you upgrade to 0.10.x, downgrading to 0.9.x afterwards may not be possible anymore.

  • So it's compatible? Thanks for the info. – Patton000 Jul 3 '15 at 13:40
  • Forward compatible, not backward compatible. You can upgrade from 0.9 to 0.10, but not the other way around. – Pieter Wuille Jul 3 '15 at 15:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.