1

I got bitcoind working in the cmd prompt; Then I closed it and opened bitcoin-qt and that is now running in server mode; (bitcoinf server=1)

Then I run some simple .php on my localhost (using xampp apache engine) and this line of code is not working :

$bitcoin = new jsonRPCClient('https://user:password@192.168.0.2:8333/');

I get this error :

>  Notice:  fopen(): send of 24 bytes failed with errno=10053 An
> established connection was aborted by the software in your host
> machine.  in C:\xampp\htdocs\xampp\jsonRPCClient.php on line 132
> 
> Fatal error:  Uncaught exception 'Exception' with message 'Incorrect
> response id (request id: 1, response id: )' in
> C:\xampp\htdocs\xampp\jsonRPCClient.php:152 Stack trace:
> #0 C:\xampp\htdocs\xampp\hello.php(14): jsonRPCClient->__call('getinfo', Array)
> #1 C:\xampp\htdocs\xampp\hello.php(14): jsonRPCClient->getinfo()
> #2 {main}   thrown in C:\xampp\htdocs\xampp\jsonRPCClient.php on line 152

and here is my port status :

enter image description here

I am running bitcoin-qt in server mode (=1) and the port status for 8333 is "sent"

my XAMPP Netstat also shows that the port is properly open :

enter image description here

I also tried this line

jsonRPCClient('https://bitcoinrpc:12345@192.168.0.2:8333/');

because my bitcoin.conf is

server=1 rpcuser=bitcoinrpc rpcpassword=12345 listen=1 rpcssl=1

still no joy - get the same error !

WHAT MORE CAN I DO to get it to work !!!!

Any help much appreciated !

1

RPC port is 8332 by default for mainnet, 8333 is the Bitcoin network protocol port.

Also, be sure to set the rpcallowip variable if you are connecting to the node from another host on the network (non-localhost connections are blocked by default).

  • Unfortunately that still does not resolve it. I am convinced this is a windows 7 problem and that if I run it on the server it will work. would be great if someone knows how windows is blocking this – Aussie in Perth Jul 21 '15 at 13:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.