0

!setBlockIndexCandidates.empty() Bitcoin Core 0.11 error

Hello,

I have a problem with the Bitcoin Core v. 0.11 software!!!

I installed the software today and after a long wait (downloading block source - 5 years) I closed the application and when I tried to start it again I received this error:

"Assertion failed! File: main.cpp, Line 2287 Expression: !setBlockIndexCandidates.empty()"

If I click Ignore on the error window the program start but with "No block source available" so it can't continue the download. And when I close the program I receive a FATAL ERROR message: "see debug.log for details"

Can somebody tell me how do I fix this error or what do I do next? And another thing... I was sent today some Bitcoins and I am asking if the sun can be recovered somehow?

Thanks!

debug.log

  • Can you take the last 30 lines or so of %APPDATA%\Bitcoin\debug.log and edit them into your answer? – Nick ODell Aug 10 '15 at 6:08
  • Did you try to delete the blocks and chainstate directory in the bitcoin datadir? – Jonas Schnelli Aug 11 '15 at 13:23
1

I had exactly the same problem with litecoin 0.15.1 and it helped me to run it with --reindex option on the command line. I only had to do it once...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.