1

I have generate bitcoin address from testnet server.

but I can't get any btc in those address. i tried many times and I failed.

can anyone explain me that is the reason? whay i can't get btc on those address.

note: i used regtest server for same purpose and my rpcport is 18332(regtest and testnet)

0

1 Answer 1

2

I've just tested TP's faucet and it worked (green success text).

Are you sending to a testnet address (begins with m, n, or 2)? I'm thinking you may be inadvertently using Mainnet or Regtest mode (beginning with 1 or 3).

Ensure your Bitcoin.conf file has testnet=1 in it, or use the -testnet flag on the command line. Also be certain your blockchain is fully synched (this will take many hours, unlike regtest mode)

Go into BitcoinCore's client, and try getnewaddress in the console (help > console). Then copy/paste that address into the faucet, complete the CAPTCHA, and the coins will have been sent. You will need to have a completely synched blockchain before the coins will "appear".

7
  • "bitcoin.conf rpcuser=bitcoinrpc rpcpassword=random string testnet=1" also I didn't found getchangeaddress in bitcoin-cli. what is the problem??? Aug 14, 2015 at 8:03
  • note: main net and testnet rpcpassword is same Aug 14, 2015 at 8:11
  • @ShahadatHossain sorry! I meant getnewaddress Aug 14, 2015 at 8:12
  • I tried but I can't get any testnet bitcoin for those new addresses. what should I do now? Aug 14, 2015 at 9:44
  • I don't know. You'd need to tell me specifically what the problem/error is Aug 14, 2015 at 11:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.