1

I'm really new to bitcoins so being naive I've jumped in downloading a wallet (bitcoin core), got my address and set off buying 1 bitcoin.

Now I bought the bitcoin and it all went fine, I went to my wallet to find nothing there, I got a little concerned thinking it sent them elsewhere but after a check on blockchain it said they were sent to my address. After some googling I realised I hadn't let bitcoin core download the full blockchain data and read that all I had to was wait for my blockchain to download and my bitcoins would appear in my wallet. So I went to sleep. I checked my laptop in the morning to see it was sailing through the block chain and only had 1 year to go.

I've came in from work and my Portable HDD is making all sorts of noises but still being read and written to. My bitcoin core has frozen though, not long after the time I checked it this morning, I closed it and tried to reopen but it has asked me to create a path to download the blockchain? I've also gotten a new bitcoin address! I'm seriously flapping now!

So exited it and tried to open the wallet.dat file I saved the previous night but it never saved after I bought the bitcoin! This has been opened and my bitcoin address is now the same but now bitcoin core says indexing blockchain or something.

The main question is: Have I lost my bitcoins or do I just need to wait on the indexing and they will appear? The blockchain says they are still registered to that wallet.

2

If you saved a copy of your wallet, I don't think you have lost your bitcoins. The bitcoin core client makes 100 addresses ahead of time (you don't have just 1 address!), and they are all stored in the wallet.dat file.

Just wait until you client has finished downloading the blockchain, or follow the steps here to get them out without waiting!

  • I tried following the steps from that but i dont know what to do now i have my private key? Can you help with that?? – Rememberthefallen Aug 27 '15 at 18:59
  • I never saved my wallet after i finished the bitcoin transaction. – Rememberthefallen Aug 27 '15 at 19:00
  • @Rememberthefallen Can you open the debug console? If so, do validateaddress {{your address}}. It will return some stuff, look for the field called ismine. Do you see it? – morsecoder Aug 27 '15 at 19:18
  • @Rememberthefallen You don't need the private key explicitly in those steps that I linked to. And it's okay that you didn't save if after the transaction, if you saved it before you will still be able to get access to your funds. – morsecoder Aug 27 '15 at 19:20
  • @Rememberthefallen, glad to hear you got most of your coins back! Make sure you upvote and select my answer since it helped you. (Also, you may want to edit your comment to not specify that you use Nucleus on a public website like this...) – morsecoder Aug 28 '15 at 20:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.