2

I'm trying to compile from latest tag the bitcoin repo and in my use case scenario ZeroMQ support would definitely help me.

Reading the documentation I realized this rudimental docker container. The Dockerfile installs the libzmq3-dev dependency and I define these configurations in the bitcoin.conf file.

The result is that inside the container there isn't any bind for the defined mq enpoints and I cannot realize where the error is.

Could someone please help me to enable mq publish mechanism?

Update: Now the bitcoin.conf file used is this running in in debug it logs this debug_log.txt.

  • 2
    Your prune line looks weird. – Pieter Wuille Nov 26 '15 at 0:42
  • @PieterWuille: probably I misunderstood the help line that describes the option. I suppose that the weirdness stands in the angle braket. Am I right? – Dario Nov 26 '15 at 8:19
  • @PieterWuille I changed the prune option with the 1000 value and the log report an incompatibility with the txindex. Removing the prune at all, I cannot expose the mq enpoints. Is there anything I could do trying to spot the problem? – Dario Nov 26 '15 at 12:43
  • You cannot enable both txindex and prune. Pick one. – Pieter Wuille Nov 26 '15 at 13:05
  • infact I've correct removing the prune option. The fact is that there isn't any mq bound on ports specified. – Dario Nov 26 '15 at 13:08
1

So after some investigations I realized that ZMQ support is not present on the latest tag on the repo (this line was in charge of giving me the latest tag).

So I think that my problem is by now resolved by using master as building branch.

Thanks at all, Dario.

  • Note that, latest packages from ppa:bitcoin/bitcoin contain ZMQ support – Oleksandr Fediashov Apr 3 '17 at 7:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.