2

Been racking the brain forever, ubuntu noob, but wiped W7 for Ubuntu, updated and upgraded, checked out bfgminer and cgminer, both when running good .bat file with good pool, but they say no device?

Adding zus:all or just all or just auto wont add the X3 Thunder I attached via USB to the laptop? I have had issues another laptop like this and had to use a special driver.

Any ideas or directions are greatly appreciated. Also I'm not against either cgminer or bfgminer, but id like to get one working on this ubuntu laptop at this point, I have a device that should be hashing and i cannot get working.

  • Would be advantageous if you rephrase the question to the exact steps youve taken, use the "CODE" take to paste console output, for long console use pastebin with the correct synthax. First idea is chown -R USER:GROUP /dev/device and try sudo apt-get install usbmount. PS pls include versions as well, which ubuntu do you use? Check synaptic -> search -> firmware, may you dont have the correct firmwre - without facts just guessing here :) – Aurigae Nov 8 '16 at 8:32
0

Are you running the miner as root? Do the devices show up when you run lsusb ?

In my experience, your user doesn't have access to the buses to talk to the devices, but putting sudo at the start (running as root) let me see and talk to my devices.

(I'm using cgminer compiled from source for LTC mining rather than BTC, but the principle should be the same.)

  • Yes, running as root, installed as sudo su, then installed and compiled, it opens to the pool, but wont connect the device, ill try the lsusb and report back later tonight when at cpu, thank you for your answer – user30998 Dec 8 '15 at 15:59
  • BFGMiner has no such issues normally and should not require root. – Luke-Jr Aug 9 '16 at 23:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.