3

A few weeks back, a client wanted to pay me in bitcoin so I created an account at blockchain.info. The transaction went through and the coins show in my account.

When I tried to use it however, I got an error message saying "Private key does not match bitcoin address." I tried working with the blockchain.info support but they kept stealth closing the ticket on me.

At this point, I tried exporting the private keys from blockchain and importing to another site (coinkite). The coinkite import private key routine resolved the private key of blockchain.info to different public addresses. I'm out of options so I figured I'd pose this problem to the forum.

Thanks in advance for any help.

  • Blockchain.info is a bit notorious for screwing up private keys. Although i haven't heard new issues as of late. If this one is their fault, it's huge. However, unless someone recognises your problem and can tell you what you did wrong, I think this question is more suitable for reddit /r/bitcoin – Jannes Jan 10 '16 at 15:42
  • Thanks, Jannes. I'll take your advice and post on reddit, possibly with some screenshots cleaned of data to show a little proof. This is a nightmare. – Prity Jan 11 '16 at 16:27
  • I can confirm that I have the same problem here... I have address that I stored at April 2014. It is now appearing in the "Imported Addresses" section. When I try to export private key I can do that in 2 formats: base 58 and WIF. When I choose WIF and reimport the result to the wallet, I get a different address! Base 58 looks ok, but on the other hand the format looks bad and I can't use it in other places. – gamliela Jan 14 '17 at 11:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.