1

I am using Fedora 22, 32bit OS and have Antminer U3 for mining operations

got the cgminer source code from GIT: git clone https://github.com/bitmaintech/cgminer

while running ./configure --enable-icarus the command ends up in error as below

./configure: line 11972: -pthread: command not found
checking libudev.h usability... no
checking libudev.h presence... no
checking for libudev.h... no
configure: error: "udev support requested but libudev not installed"
configure: error: ./configure failed for compat/libusb-1.0

I tried using system libusb, but no success

./configure --enable-icarus --with-system-libusb

checking for pthread_create in -lpthread... yes
checking for library containing addstr... no
configure: WARNING: Could not find curses library - if you want a TUI, install libncurses-dev or pdcurses-dev
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for LIBUSB... no
configure: error: Could not find usb library - please install libusb-1.0

libusb is part of systemd package and my system has latest installed. checked from

sudo dnf upgrade systemd

command returned Nothing to do.

Could you please help where i could be going wrong in setting up CGMiner ?

PS: I tried bfgminer, but ended up in errors.

0

I was able to get cgminer to build the icarus extension on a fresh CentOS system like so:

yum install git
git clone https://github.com/bitmaintech/cgminer
cd cgminer/
yum install -y autoconf make automake gcc gcc-c++ kernel-devel libcurl libcurl-devel
yum install libudev-devel
./autogen.sh
./configure --enable-icarus
make
./cgminer

So I think you're missing the package libudev-devel. (It might be named something different on Fedora 22 - I don't know.)

  • That worked like charm. There were 2 packages missing kernel-devel and libudev-devel. after they were installed the ./configure --enable-icarus worked fine. Thanks Nick – Rahul Jadhav Feb 4 '16 at 14:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.