2

I've tried my best to follow the installation instructions for a headless Debian server found on github.com/bitcoin and bitcoin.org/en/full-node. However, I can not figure out if everything installed correctly. I don't know the right sanity checks.

To install bitcoind I used wget to download the 0.11.2 tar/zip file from bitcoin.org. I installed all the dependencies through apt-get listed on github. I used wget to download Berkeley DB4.8 and used "make install" to presumably install db4.8. Finally, I used "sudo install" to add the bitcoind binary to "/usr/local/bin".

I can run bitcoind and interact with it using bitcoin-cli. However, how can I determine if the installation is truly a success? How can I verify that bitcoind is using Berkeley DB4.8? I have a suspicion something is off, because I could not find the bitcoin root. This instruction from github baffles me:

cd $BITCOIN_ROOT
./autogen.sh
./configure LDFLAGS="-L${BDB_PREFIX}/lib/" CPPFLAGS="-I${BDB_PREFIX}/include/" # (other args...)

I cannot use autogen.sh, because I cannot find it. Where is the $BITCOIN_ROOT? Where is the configure file? I cannot find this either. I am afraid to use the wallet and lose BTC.

  • I think part of my confusion stems from the apparent existence of two ways to install bitcoind. One way is the approach I took, which was to wget the bitcoind from the bitcoin website. Another approach is to use git. If I use git, then it seems I will have the autogen.sh and configure files. – wherestheforce Feb 18 '16 at 5:48
  • My node is recognized by the website bitnodes.21.co – wherestheforce Feb 18 '16 at 5:49
  • I now understand why I was confused. I followed the instructions for installation from bitcoin.org, but then tried to verify this installation by following the instructions from github. The source code is not included in the bitcoin.org download, so that explains why I couldn't find any of the files referenced in the github instructions. – wherestheforce Feb 18 '16 at 7:08
1

autogen.sh located in bitcoin source root. To use it you should have pkg-config libtool installed.

  • I do not know where my bitcoin source root is located. If I try "which bitcoind" I get "/usr/local/bin/bitcoind", which is just a binary file. If I go to the bitcoin package I downloaded there are only three folders: bin, include, and lib. None of these folders has an autogen.sh file. – wherestheforce Feb 18 '16 at 5:41
  • 2
    you download a binary image. The instructions you try is for source code. (bitcoin.org/bin/bitcoin-core-0.11.2/bitcoin-0.11.2.tar.gz) – xbtc Feb 18 '16 at 11:03
1

Building from source is an issue because the BerkeleyDB version shipped with Debian Jessie (Stable atm) is different from the version used with bitcoind. For this reason I personally chose to run the prebuilt binaries and verify the checksums after downloading (one could argue this isn't as secure as building the source yourself).

BITCOIN_ROOT and BDB_PREFIX are defined paths (in your environment) to the bitcoin root source directory (where you are building the source) and the BerkeleyDB library directory respectively. You need to define these in your shell before calling those commands. The only one of real importance is BDB_PREFIX as you could simply cd into the source directory yourself before running the build commands. LDFLAGS="-L${BDB_PREFIX}/lib/" and CPPFLAGS="-I${BDB_PREFIX}/include/" are telling the compiler where to find the BerkeleyDB library and include files respectively.

If you are not a programmer and lack experience building source code, you might consider just using the prebuilt binaries instead. I would highly suggest you verify the checksums of the archives you download first before using any of the binaries within. This can be done by comparing the hash you calculate with the hash provided on the bitcoin.org website under the link Verify release signatures:

$ sha256sum bitcoin-0.12.1-linux64.tar.gz

Obviously, use the correct signature version file that matches the file version you download.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.