1

I am experiencing a recurring problem with my BitCoin Core wallet. The main issue here is that I get an error message every so often as the program is updating the transaction blocks. Assertion failed error

Please see the jpeg in the link above, this is the exact error message I get when the client is updating.

Details:

  1. I am using BitCoin Core V 12.0

  2. I have tried reindexing using : c:\Program Files\Bitcoin\bitcoin-qt.exe -reindex

  3. I have tried to reinstall the client, then restart my computer, then open and let it update.

  4. I haven't yet tried a RAM test to see if my RAM could be the source of corrupted data

  5. I'm running Windows 7 OS 64-bit, 8Gb DDR3 RAM

I feel its something that can be fixed with a patch, but I could be wrong. If anyone has a solution that I can try myself, that would be most welcome.

1

It is possible that you are running out of RAM or HDD space. Check this github report from a user with a similar issue. If this is not the case then I would run a memtest and see if you don't have an issue with your RAM.

  • Hi Mark, thanks for the quick reply! I have 90Gb of free space on HDD and will try a RAM memtest next. Will update this post when thats complete – Ragnarok Mar 16 '16 at 23:59
  • Hello again, I tried to use a RAM test software and mounted its image onto a USB stick. I followed their instructions it and after I went to enter set up, i could see it there under BOOT section but could not activate it when it was highlighted. I pressed enter when it was high lighted and nothing happened. If anyone can recommend another course of action to correct the problem as seen in the JPEG above, please give us your take on this. – Ragnarok Mar 23 '16 at 3:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.