2

I would like to know the best way to update my RaspNode (rPi 2 B+) to the 0.12.1 bitcoind version.

I did

sudo apt-get install bitcoind

I also did this:

Erased /bin/bitcoin folder

then into /bin/

git clone https://github.com/bitcoin/bitcoin.git
./autogen.sh
./configure --enable-upnp-default --disable-wallet
make -j2

but it's still the same version 0.11.2

1

You should uninstall the installed version first completely with sudo apt-get remove bitcoind before manually building the binaries from source. Make sure that you backup your wallet (and eventually Blockchain) first (so Keep your data-directory).

Don't run the build in teh bin folder! The sudo make install command will install more than just the binary on your machine! Use e.g. /home/git/bitcoin/ to clone the repository and run your configure and make commands there.

Then instlall bitcoin like described on github. after your make -j2 command you should run sudo make install to install bitcoind on your computer. (Binaries are intalled under /usr/local/bin/).

I have installed it on my raspberry Pi a week ago. Works fine :-)

Blockchain-sync lasts almost forever ....

If didn't use the --disable-wallet flag. You could use the wallet with bitcoin-cli

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.