1

I am running bitcoin-qt on the testnet. The count of the last block is 787794 which is way ahead of what I see on blockchain explorers such as https://test.webbtc.com/, which shows the last block as 787747. Why is there this difference ?

1

Apparently, there is a fork between 0.12.0 and 0.12.1 nodes.

Testnet is used to test new features of Bitcoin before they are released on the main network. Apparently, the newer version of Bitcoin created a block that was invalid under the rules of the older Bitcoin version. This caused the network to split, as the two versions now created two competing blocks at the same height, and are following separate chains.

Apparently, the softfork activation is being tested, which may cause your experience:

<phantomcircuit> nope
<phantomcircuit> like 50% of the hashing power currently on testnet randomly drops out for days at a time
<phantomcircuit> and im messing with the timestamps to get many many many more blocks than there should be
<phantomcircuit> the two things combined result in soft forks activating with way less than 95% of the hashing power
  • Can you please elaborate. I didn’t get you. I am quite new to Bitcoins – jgm Apr 26 '16 at 14:48
  • @jgm: I've updated my answer. – Murch Apr 26 '16 at 14:57
  • That patch doesn't seem to create any consensus changes. Why would that be the cause? – Nick ODell Apr 26 '16 at 16:18
  • Good point, I got linked to it on IRC, didn't check it thoroughly enough. I've seen it both suggested that it had something to do with OP_CHECKSEQUENCEVERIFY or with GBT, haven't been able to find more information. – Murch Apr 26 '16 at 16:33
  • @Murch I think that seems to be the answer. I run the testnet on two machines and both are way ahead of other blockchain explorers. Also I run the version 0.12.1 – jgm Apr 26 '16 at 19:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.