4

Good Evening,

I recently installed Bitcoin Core v0.12.1 on my home server (running Windows 7) and wanted to allow it to accept incoming connections and used the guide found here: https://bitcoin.org/en/full-node#windows-7 to ensure I did everything that was needed. Unfortunately, it hasn't been showing any incoming connection and when I used the connection tool recommended in the guide (https://bitnodes.21.co/#join-the-network), it says my server is unreachable.

I have already setup port forwarding for port 8333 to both my server's IP address, 192.168.1.105 (wireless) & 192.168.1.129 (ethernet). I ran a port scan on the following websites and they all indicate that Port 8333 is open:

  1. Ping.eu Port Check
  2. WhatMyIP Port Scanner
  3. T1 Shopper Port Scanner

(I would provide links for the above scanners, but I cannot post more than 2 links)

I also created two rules in Windows Firewall (under Inbound Rules) with the following properties:

  1. Local Port - 8333
  2. Remote Port - All Ports
  3. Scope - Local & Remote IP address set to Any IP Address
  4. Domain, Public, and Private all checked
  5. All programs that meet the specified conditions checked
  6. Set to allow the connection
  7. Rule is enabled

There are two rules with the above settings, one for TCP and one for UPD. Even with all the above setup, the "Join the Network" tool on Bitnodes website (second link from the top) still says my node is unreachable and the debug window inside the program shows 0 incoming connections and 8 outgoing connections.

I'm not sure what else needs to be setup since I completed everything in the guide and port 8333 is definitely open. Any help or information with this issue would be greatly appreciated. Thank you in advance.

Dominick

  • 1
    Why do you have two port forwarding rules set up? Why not just set a rule to forward to your ethernet interface? – Nick ODell May 5 '16 at 6:01
  • Originally I did, but when it wasn't helping the connection I decided to add the second rule just to see if it would help, which it hasn't. Right now my total connections is down to 5 outbound and still no inbound. – Dominick M. May 8 '16 at 3:19
  • Wait for whole chain. Without it your PC will never be full node... – Xawery Wiśniowiecki Jan 16 '17 at 20:43
3

I had the same problem. The port was open, but the test at bitnodes.21.co would fail. However after my Bitcoin client downloaded the entire BlockChain everything worked. I used about 144 hours to download the entire chain with a 150Mbps fiber line.

Before the entire chain was downloaded the test at https://bitnodes.21.co/#join-the-network would give an "Unreachable" error. After it downloaded it changed to Green saying it's reachable.

So you just have to be patient :)

1

I had the same problem after following all of the usual steps. I waited and it still didn't work. I had to change my computer's firewall (in the Inbound Rules) for the Bitcoin Core (highlighted one below) to have a Private Profile. It was "Private, Public" at first.

enter image description here

You can see if you have both directions working from this icon. Both parts of the U's to the left of the check mark below should be bold. If one of the directions isn't working, it won't be a bold line.

enter image description here

Also you can change the maximum number of connections here:

Bitcoin Core - Wallet > Settings > Options > Open Configuration File

I think mine was only set to max=3 at first.

0

If all else fails you may try "Port Triggering" whereby your router will open specified ports for incoming traffic based on triggers. I'm using the Motorola Surfboad / Arris router. I had to enable this option even though I had set Port Forwarding as required. Good Luck. Rob.

0

On the inbound rule that you have created on your Windows Firewall, go to the Advanced tab and set the 'Edge Traversal' setting to Allow Edge Traversal, by default its on Block Edge Traversal.

I faced a similar problem at first but after changing the above setting, i started getting incoming connections.

ThanksAllow Edge Traversal

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.