2

I'm running the puddinpop rpcminer-opencl.exe that came with Guiminer. I'm running it with crazy settings -gpugrid=128 -gputhreads=256 -aggression=14 on a FirePro 2270 workstation card, and it's reporting about 20 GH/s which I understand is not even remotely possible. I assume something went wrong and all my hashes are broken somehow, but how do I troubleshoot this?

Update: The same miner works fine on one of my other machines. I did find this output on the console:

Build program rval=0
build STATUS:
build LOG:C:\Users\Sean\AppData\Local\Temp\OCLF1AC.tmp.cl(51): warning: attribute "vec_type_hint" ignored
__kernel __attribute__((vec_type_hint(uint))) WORKGROUP void opencl_process(__global opencl_in *in, __global opencl_out *out, const uint loops, const uint bits)
^
Create kernel rval=0
Done allocating OpenCL resources for (128,256)
Finding best configuration step end (128,256) 6ms  prev best=9223372036854775807ms
Done allocating OpenCL resources for (16,16)

So the warning is odd, but also that last extra (16,16) line doesn't show up on my other machine that works.

Update 2: With "crazy" settings I get no shares. If I run with no options, it reports 10 MH/s and seems to get about one share every 10 minutes. So somehow changing the settings makes it generate no shares at all!

1

I agree, that 15W card should calculate hashes slower than anything listed at https://en.bitcoin.it/wiki/Mining_hardware_comparison - 20MH/s sounds about right. You probably misread the units (1GH = 1000MH), or the software has a bug and miswrote them.

  • Hm, I don't think it's just a decimal error because on some settings it reports normal values and for others it reports crazy ones. I guess I'll just use a different miner but I thought it was weird. – sep332 Aug 15 '12 at 23:33
0

From memory, when pool mining I can solve about 220 shares per hour with 270MH/s. You could work out an approximate hash rate based on the number of shares solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.