6

I am trying to build bitcoind on Ubuntu 16 64-bit. I have installed the dependencies and have built it fine many times on other machines.

During ./configure, I am getting

checking whether the Boost::Unit_Test_Framework library is available... yes
checking for dynamic linked boost test... yes
checking for mismatched boost c++11 scoped enums... ok
checking for SSL... no
configure: error: openssl  not found.

I have run sudo apt-get install libssl-dev and tried it, also tried brew install openssl, still no dice.

Before, I was getting a missing pkg-config at this point, even though I had installed it. I installed pkgconf and also installed it via brew, and now it's complaining about openssl, which is definitely installed.

$ which openssl
/usr/bin/openssl

Any ideas? Frankly, I'm stumped.

UPDATE:

I built openssl from source, now I'm getting this:

checking for mismatched boost c++11 scoped enums... ok
checking for SSL... yes
checking for CRYPTO... yes
checking for EVENT... no
configure: error: libevent not found.

I'm not sure what is going on... it seems it cannot find packages installed via apt-get for some reason.

  • I didn't want to set this as an answer, because it's really not. I set up a new server with Ubuntu 14 and it worked the first time. Very strange. Did some directory paths change in Ubuntu 16? – Matthew Darnell Jun 8 '16 at 21:35
  • I guess you didn't follow github.com/bitcoin/bitcoin/blob/master/doc/build-unix.md (builds fine at ubuntu 16.04), Looks like you haven't installed libevent-dev and libssl-dev. – Jonas Schnelli Jun 9 '16 at 7:25
  • I absolutely did install both of them, multiple times I uninstalled and installed via apt-get and brew, I tried both. It only progressed past each package in the ./configure file once I built from source. – Matthew Darnell Jun 9 '16 at 21:00
2

I fixed the issue by installing extra libraries, the whole list

sudo apt-get install -y autoconf g++ make openssl libssl-dev libcurl4-openssl-dev

sudo apt-get install -y libcurl4-openssl-dev pkg-config

sudo apt-get install -y libsasl2-dev

Source: https://github.com/mongodb/mongo-php-driver/issues/138#issuecomment-184749966

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.