0

My Bitcoin core says ''no block source available'' I have already tried the following things to resolve the problem: - Unchecked proxy in connection (this wasn't checked anyway) - I have downloaded bootstrap.dat but I do not know how to import this / what to do with this - I have tried the -reindex command in the console but this I hope someone will be able to help me. I have already made a ''receive'' adress which I had bitcoins transferred to before I realised I had to download the whole blockchain. I figured it wouldn't really matter considering I'd just wait it out and have access to my BTC. Now I'm really starting to panic. Thanks in advance!

  • Where did you type '-reindex'? – Pieter Wuille Jun 20 '16 at 0:28
-1

Bootstrap is not working great anymore, it will take longer to start your wallet as usual. You can better download from here.

Further check your wallet connection with https://bitnodes.21.co. It should get connections by itself.

  • Please do not suggest that people download a preindexed blockchain from you. Doing so implies they need to trust you to tell them exactly how much money everyone owns. – Pieter Wuille Jun 28 '16 at 23:03
  • is there an other way to let people download the chain then? I could change the way the RAR is created. (blockchaindownload.nl is my site) – rollo1996 Jun 29 '16 at 9:21
  • Just store the blk*.dat files, not the index/ or chainstate/ directories. That will still require fully validating the downloaded chain, but if people are unwilling to do that, they should just use a lightweight client that does neither download or validate, and not Bitcoin Core. – Pieter Wuille Jun 29 '16 at 14:05
  • okey, I will look into a change in the download system! – rollo1996 Jun 29 '16 at 14:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.