2

I'm trying to read the chainstate, and wrote a small Leveldb client to do so. When I run leveldb, it tells me Corruption: 960 missing files; e.g.: /opt/bitcoin/chainstate/890787.sst. Googling shows that Leveldb uses .sst files, but, I don't see a single one on my machine.

How do I generate these files / repair the chainstate leveldb / access it from a leveldb client?

  • Is Bitcoin Core already running? – Pieter Wuille Jul 26 '16 at 6:45
1

the default extension is now ldb https://groups.google.com/forum/#!topic/leveldb/u9izbG-pDis

Which library are you using to read leveldb? I suggest you use plyvel. It will be able to read chainstate

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.