1

These two lines (and nothing more), create an error:

var exp = require('bitcore-explorers');
var btc = require('bitcore-lib');

Error: More than one instance of bitcore-lib found. Please make sure to require bitcore-lib and check that submodules do not also include their own bitcore-lib dependency.

I could see that this issue has been documented here, as well as here, and here. I read these pages, but I am still unable to overcome the issue.

Can someone please help? How do you do when trying to import different modules of bitcore?

  • Any news on this problem? According to other threads it seems rather intractable. Did you find a workaround? – Mundi Sep 15 '16 at 10:00
  • I have not found a solution to that unfortunately. – hartmut Oct 3 '16 at 9:10
1

I don't know if that's the right method but it does work.

delete global._bitcore
var bitcore = require('bitcore-lib')
  • Is it the right way to do..? and it'll not stop bitcore-lib right..? – Codebrekers Sep 20 '17 at 6:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.